TechSpot

I'm getting popups in I.E. about every minute

By computerman
Sep 3, 2007
  1. Please help me my computer is infected with something

    I don't know much about fixing computers

    http://s219.photobucket.com/albums/cc191/Ultrabomb/?action=view&current=ie.jpg

    That's what ghost security suite recorded of it

    I've also just noticed I'm getting something similar to the post of taranis; i think it has something to do with svchost, as it says in appdefend. Also in my processes there appears to be 7 processes of svchost.exe running; 4 of which are SYSTEM, 1 is LOCAL SERVICE, and the other 2 are NETWORK SERVICE. Could just be normal. So basically i can be using Firefox and a minute later a page in I.E. pops up.
     
  2. TimeParadoX

    TimeParadoX TS Rookie Posts: 2,273

    Hello and welcome to Techspot.

    You're running a outdated version of HJT.

    Very Important: Make sure you`re running the latest version of HijackThis. Currently version v2.0.2.

    Visit the TrendMicro download site for HijackThis HERE. Click on the last link "Download HijackThis Executable". When a popup comes up asking to run or save file, click on "Save".
    Save the file in the directory as C:\Program files\hijackThis\HijackThis.exe. ( You'll need to create it )

    THIS IS VERY IMPORTANT.

    Rename the Hijackthis.exe file to Analyze.exe. This is because some malware can hide from HijackThis.exe. Right click the HijackThis.exe file and choose rename. Click in the title box and press the delete key to clear what`s there, type Analyze.exe and press the enter key. Right click the Analyze.exe file and send to desktop(create shortcut).

    Under no circumstances should you add any items to the HJT ignore list.


    DO NOT PUT HJT ON THE DESKTOP OR IN A TEMP FOLDER


    Very Important: Before deciding whether you should clean or reformat your system, go and read this thread HERE and decide what it is you want to do.

    If after reading the above, you wish to clean your system, do the following.

    Go and read the Viruses/Spyware/Malware, preliminary removal instructions. Follow all the instructions exactly.

    Post fresh HJT, AVG Antispyware and Combofix logs as attachments into this thread, only after doing the above.

    Also, let me know the results of the AVG Antirootkit scan.

    This thread is for the use of Computerman only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  3. computerman

    computerman TS Rookie Topic Starter Posts: 16

    Ok I updated hijackthis, i gave it it's own folder in program files and renamed it to analyze.exe and made a log

    i previous fast scan i'll do a full scan now
     

    Attached Files:

  4. Rik

    Rik Banned Posts: 3,814

    Could you also run combofix as per the instructions and post its log.



    This thread is for the use of Computerman only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  5. computerman

    computerman TS Rookie Topic Starter Posts: 16

    Hi, i just downloaded combofix but when I ran it i got some strange red box that said
    --------
    COMSPEC ERROR !!!

    THE ABOVE ENVIRONMENT VARIABLE WAS FOUND TO BE CORRUPT.

    combofix has attempted to repair & will need to be restarted.
    please run combofix again & inform the person helping you.

    press any key to exit.
    ----------------

    am i doing something wrong?

    also i did a full scan with AVG Anti-spyware and got alot of the same tracking cookies from before- nothing more. My computer crashed before i could save a copy due to a power surge from the storm outside
     
  6. Rik

    Rik Banned Posts: 3,814

    Try running it with your internet connection disabled and tell me what happens.


    This thread is for the use of Computerman only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  7. computerman

    computerman TS Rookie Topic Starter Posts: 16

    I did that but the same thing happens; a blue screen in a cmdbox pops up and says please wait combofix is preparing to run, and then then it turns red with the message in previous post. Do i need to be in safe mode?
     
  8. Rik

    Rik Banned Posts: 3,814

    Hmmm, your pc isnt happy. Give it a try in safe mode, it wont be as effective but atleast it may run.



    This thread is for the use of Computerman only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  9. computerman

    computerman TS Rookie Topic Starter Posts: 16

    This is from safemode. Then it rebooted into normal mode and did what it needed to do hopefully
     
  10. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    You might want to copy and paste these instructions into a notepad file. Then you can have the file open in safe mode, so you can follow the instructions easier.

    Boot into safe mode, under your normal user name(NOT THE ADMINISTRATOR ACCOUNT). See how HERE.

    In Windows Explorer, turn on "Show all files and folders, including hidden and system". See how HERE.

    Go to add remove programmes in your control panel and uninstall anything to do with(if there).

    SpywareBot
    Viewpoint
    MEGAUPLOADTOOLBAR
    Prevx2

    Close control panel.

    Click start/run and type services.msc into the run box and press the enter key.

    When the window appears, maximise it. Double click on the following services(if there) and select stop if they are running. Set the startup type to disabled. Click apply/ok for each service you disable.

    SpywareBot Scanning Engine

    Close the services window.

    Open your task manager, by holding down the ctrl and alt keys and pressing the delete key.

    Click on the processes tab and end process for(if there).

    SpywareBotSrv.srv.exe
    SpywareBot.exe

    Close task manager.

    Run HJT with no other programmes open(except notepad). Click the scan button. Have HJT fix the following, by placing a tick in the little box next to(if there).

    O2 - BHO: Google Web Accelerator Helper - {69A87B7D-DE56-4136-9655-716BA50C19C7} - I:\Program Files\Google\Web Accelerator\GoogleWebAccToolbar.dll (file missing)

    O3 - Toolbar: Google Web Accelerator - {DB87BFA2-A2E3-451E-8E5A-C89982D87CBF} - I:\Program Files\Google\Web Accelerator\GoogleWebAccToolbar.dll (file missing)

    O4 - HKCU\..\Run: [SpywareBot] I:\Program Files\SpywareBot\SpywareBot.exe -boot

    O23 - Service: SpywareBot Scanning Engine (SpywareBotSrv) - Unknown owner - I:\Program Files\SpywareBot\SpywareBotSrv.srv.exe

    Click on the fix checked button.

    Close HJT.

    Locate and delete the following bold files and/or directories(if there).

    I:\Program Files\SpywareBot<Delete the entire folder.
    I:\DOCUME~1\Guest\APPLIC~1\MEGAUPLOADTOOLBAR<Delete the entire folder.
    I:\DOCUME~1\steven\APPLIC~1\MEGAUPLOADTOOLBAR<Delete the entire folder.
    I:\DOCUME~1\steven\APPLIC~1\Viewpoint<Delete the entire folder.

    Reboot into normal mode and rehide your protected OS files.

    Post fresh HJT and Combofix logs.

    Regards Howard :wave: :wave:

    This thread is for the use of computerman only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  11. computerman

    computerman TS Rookie Topic Starter Posts: 16

    I would have posted sooner but my ISP had like a crashdown in my whole area so many people were without internet. I've followed the steps you told me and I've attached a fresh ComboFix and hijackthis log. Ever since I first ran combofix in safemode yesterday the pop ups have seemed to call a ceasefire
     
  12. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    You might want to copy and paste these instructions into a notepad file. Then you can have the file open in safe mode, so you can follow the instructions easier.

    Boot into safe mode, under your normal user name(NOT THE ADMINISTRATOR ACCOUNT). See how HERE.

    In Windows Explorer, turn on "Show all files and folders, including hidden and system". See how HERE.

    Locate and delete the following bold files and/or directories(if there).


    I:\WINDOWS\752742F60F424BC4965DCCF3ADB42892.TMP

    Reboot into normal mode and rehide your protected OS files.

    Other than the above, your log files are clean.

    Turn off system restore.(XP/ME only) See how HERE.

    Now, turn system restore back on. This will have deleted all your old restore points and any nasties that are in them. It will also have created a new, clean restore point.

    If you have any further virus/spyware problems, please post in this thread.

    Regards Howard :)

    This thread is for the use of computerman only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  13. computerman

    computerman TS Rookie Topic Starter Posts: 16

    Ok i deleted the folder you asked me to delete in safe mode, I disabled then re enabled system restore. I am still getting no more pop ups from Internet Explorer. I don't know if this is relevant or not but I had downloaded prevx (supposedly a virus remover) prior to the infection then uninstalled it later because I didn't like it. Anyways, if that's it thank you very much. I'll post back here if I have any further problems.
     
  14. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Prevx is ok, but in my opinion, it suffers from too many false positives.

    Regards Howard :)

    This thread is for the use of computerman only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  15. computerman

    computerman TS Rookie Topic Starter Posts: 16

    I just scanned with AVG Anti-spyware 7.5 and it says that I have Rootkit.agent.eq. Should quarantine it with AVG Anti-spyware or is it from a program you had me use(for example: ComboFix)?
     
  16. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    It`s in the I:\qoobox folder. This is the Combofix qurantine folder, delete the whole folder.

    Regards Howard :)

    This thread is for the use of computerman only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...