Installer Error

By Rich88
Jan 3, 2005
  1. Everytime now i try to install a new driver for my video card or try to roll back the drivers i get an error.

    The error says: Device installer error: Windows could not load the installer for display.

    Anyone have any idea? Help would be great.
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Your system specs would help!!

    Have you tried completely uninstalling the video drivers?

    Also any antivirus software you are running should be disabled when installing or uninstalling drivers.

    Regards Howard :grinthumb
  3. Rich88

    Rich88 TS Rookie Topic Starter Posts: 17

    Dell computer 512mb ddr ram
    pentium 4 processor 2.66 ghz
    windows xp home edition
    40gb hdd
    nvidia geforce fx 5200 128 mb video card

    I've tried uninstalling the card and reinstalling the card but i got the same error. I had to restore my computer to get the drivers back.

    In the past when i updated the drivers it did fine. It seems like an all of a sudden thing.
  4. Rich88

    Rich88 TS Rookie Topic Starter Posts: 17

    NvM i fixed it i uninstalled windows xp sp2 and reinstalled it and that seemed to do the trick.
  5. tdong

    tdong TS Rookie

    I had the same probelm before. I hve to unistall Windows XP SP2 and then install the display adapter driver. Everything was working fine. Finally I reistall SP2.
    Hope this will work for you.
  6. wajvonk

    wajvonk TS Rookie

    Re-installing SP2 seems over the top. Try this first:
    Find "desk.cpl" in c:\windows\system32\dll cache and copy it to system32.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...