Intermittent blank screen

By Hodsocks
Mar 3, 2015
Post New Reply
  1. I am having an intermittent issue with my screen not waking up. It goes to sleep after 10 minutes normally but just occasionally it doesn't come back on. usually I have to reboot the pc. I tried a different monitor which worked fine, when I reconnected my normal monitor it also worked fine. The monitor power light flashes to indicate its in sleep mode but doesn't want to wake despite moving mouse or pressing keyboard. The graphics card is only a couple of months old and the screen is over 5 years old.
    This problem only happens maybe once a month, the rest of the time it works as normal. Any suggestions gratefully received.
  2. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

    First, are you doing anything specific when this occurs, I.e. a particular game, video rendering, etc.? Second, is there dust build-up in your system? Check especially your video card fan.
    Last edited by a moderator: Mar 3, 2015
  3. No, doing nothing specific, today for example I was doing my accounts, went downstairs, came back and screen blank, tuned screen on and off and finally rebooted computer. Sometimes may be on internet, streaming videos, it seems to be completely random.
  4. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

    As Guest are you the OP Hodsocks? If so did you check for dust as I suggested? How is the air flow? Try this: get a small fan and put it on its low setting. Now open your case's side panel and have the fan directly blow into the case. Then do your normal routines. What is the result?
  5. dividebyzero

    dividebyzero trainee n00b Posts: 4,891   +1,258

    Operating system and motherboard model?
    Windows 7 and Asus motherboards have a long-standing issue with waking from sleep/hibernation, even after setting power management preferences in the OS, and enabling USB devices to wake the system.
    If you get a blank screen in normal usage it could be your drives or SATA port - especially if the screen is dark but the mouse cursor is still visible.
    If this is the case, power down and check that the power and SATA data cable connections are firm (and not under tension) at both the hard drive and the motherboard port. If they both seem OK, I would swap out the SATA cable for another just to make sure that the cable isn't broken. If that doesn't change the behaviour try plugging the SATA cable into a different SATA port on the motherboard.
    Last edited: Mar 3, 2015
    Route44 likes this.
  6. Hodsocks

    Hodsocks TS Guru Topic Starter Posts: 370

    Inside of case is fairly clean as I regularly clean it out, airflow is OK as there are 4 120mm fans in the case. The mobo is ASUS and operating system is 8.1, I have not had problems before and had the board for several years now without issues.
  7. bazz2004

    bazz2004 TS Evangelist Posts: 1,213   +200

    "This problem only happens maybe once a month, the rest of the time it works as normal."
    Wait until it's recurring much more frequently then start to worry about about it.
  8. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

    As dividedbyzero advises, check your SATA cable connections. They are notorious for coming loose. Also, they can go bad.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...