TechSpot

Internet Connection problems

By Kneo
Sep 5, 2008
  1. Hello all,

    I am in need of some help. I just signed up for the Mediacom Online Max and should be getting up to 20mb of download speed. When I tested this I am getting closer to 2mb. When I plug the computer directly into the modem I am close to the 20mb but when I plug it back into the router I only get about 2mb. Here is my configuration with router

    The modem is from Mediacom and is used for my internet connection and phone service from Mediacom.

    The modem is connected to a Dlink DGL-4500 router and the router is connected to a Dlink DSS-24+ 24-Port 10/100 Switch.

    Through all that I have two desktops, a Wii, Xbox, PS3, LocationFree and Tivo wired into both the switch and the router. I also have a wireless network camera and a tivo that connects through wireless.

    As I said, when I connect one computer directly to the modem I am getting the higher speeds but when I connect through the router and switch it slows down to 2 mb. Does anyone have any suggetions?

    Thank you
     
  2. NetCablesPlus

    NetCablesPlus TS Maniac Posts: 228

    Start off by downloading and installing any firmware updates that may exist for your router. Is it the hardwired PC that is only getting 2Mb or is it one of the wireless?
     
  3. jobeard

    jobeard TS Ambassador Posts: 9,331   +622

    divide and conquer; disconnect the switch and test only the router connected devices.
    If the router will not perform, then it needs attention or firmware update.

    PING is not a good performance testing tool; use http://www.speakeasy.net/speedtest/ instead :)
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...