TechSpot

Internet explorer doesn't work

By giyad
Sep 11, 2007
Topic Status:
Not open for further replies.
  1. I'm having trouble with internet explorer and msn messenger. I can log into msn messenger via the web messenger that msn offers, and the only way I can do that is through Firefox. This is because for some reason, IE doesn't work. It opens and everything, but it won't surf the web. Any suggestions?
     
  2. Bobbye

    Bobbye Helper on the Fringe Posts: 16,392   +36

    "It opens and everything, but it won't surf the web. Any suggestions?"

    Please be more specific. Include information on which version of IE you're using, your operating system and installed RAM and if it's set as the default browser.
     
  3. giyad

    giyad TS Enthusiast Topic Starter Posts: 146

    Running Windows XP SP2
    512MB RAM
    Internet Explorer 7.0.5730.11
    Its not set as the default browser.

    This is the error I get when I go to www.google.com :

    "Internet Explorer cannot display the webpage"
    It then lists causes... all 3 of which are not the cause
    Most likely causes:
    1.You are not connected to the internet.
    2.The website is encountering problems.
    3.There might be a typing error in the address.

    Firefox works... so what could be the issue?
    Also, windows live messenger:
    version 8
    The error I get:
    Error Code: 80048820
    Extended Error Code: 8004840f

    I hope this helps
     
  4. BlameCanada

    BlameCanada TS Rookie Posts: 356

    Have you done the basic things like -

    1.Run CCleaner

    2.Disable 3rd part extensions (Tools/Internet options/Advanced)

    3.Run some anti spyware programs (Spybot,Ad-Aware)

    4.Try IE in 'Safe mode with networking'
     
  5. Bobbye

    Bobbye Helper on the Fringe Posts: 16,392   +36

    If you want Internet Explorer to be the default browser, set it:

    Internet Options> Programs tab> Click to CHECK 'Internet Explorer should check to see if it's the default browser> Apply> OK

    For the Error code: 80048820 , to troubleshoot the problem on a Microsoft Windows XP-based computer:
    1. Click Start, click Run, type control timedate.cpl, and then click OK.
    2. In the Date and Time Properties dialog box, confirm that the date and time settings on the computer are correct, and then click OK.

    From Messenger Support: http://tinyurl.com/2dargq

    The fix for the Extended Error is the same- correct the time and date.
     
  6. matav

    matav TS Enthusiast Posts: 174

    you must have messed up the LAN settings. check the ip, subnet mask, proxy if you need it else set it on "Automatically detect settings"
    .
    it is not a "not set as default browser" problem.
    .
    check ur firewall exceptions too.
     
  7. giyad

    giyad TS Enthusiast Topic Starter Posts: 146

    BlameCanada, I tried all those steps but it still didn't help :(

    I also tried turning off my firewall, but that didn't help. The weird thing is that firefox works. Why would firefox work and not IE7?
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.