1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Internet works on Ethernet cable but not Wifi

By San10der ยท 6 replies
Mar 14, 2016
Post New Reply
  1. Hello, I am sorry if I sound stupid and if I am using an incorrect prefix or anything but I have had this issue for a month and have found no solution. Whenever I am on the wifi it will randomly not work but still say I am connected to the wifi. It will also screw up any one else on the wifi. I have to disconnect and reconnect to fix this issue temporarly. When ever I am connected through the Ethernet cable it works 100%. I purchased an MSI GE 72 Apache Pro 003 (laptop). I have called support many times but they haven't found an answer. I returned the laptop and got a new one and the problem still happens so I know for a fact it isn't the computers malfunction. I have updated drivers and that has not solved this issue. It has something to do with my router or something with the ip on my laptop ( I don't remember what could effect it but I heard it in computer repair class ) I would appreciate help and if you want any information go ahead and ask. Sorry if I sound stupid or anything. I am just extremely frustrated with this.
     
  2. jobeard

    jobeard TS Ambassador Posts: 9,930   +735

    Make & model of your router?
     
  3. San10der

    San10der TS Rookie Topic Starter

    Sorry about the late response.
    Netgear
    Model: B90-755044-15
     
  4. jobeard

    jobeard TS Ambassador Posts: 9,930   +735

    Log into the router itself and report the version of the firmware on it now please
     
  5. San10der

    San10der TS Rookie Topic Starter

    Sorry about the late response. I was on break so I wasn't able to access the router. Its version is 06.05.12
     
  6. jobeard

    jobeard TS Ambassador Posts: 9,930   +735

    OK, that's the current version alright. Login, access the WAN side config, and set MTU to 1492
     
  7. San10der

    San10der TS Rookie Topic Starter

    Sorry if I sound stupid but where is that? I am using Frontier for internet.
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...