Invalid boot disk, insert system disk

By grimesy69
Jan 26, 2008
  1. Hi all, i have searched the forums before posting this to see if i could find anything similar but to no avail.

    My problem is as follows.

    When i boot my machine without the Xp pro disc in the Cd-rom Drive i get the invalid boot disk error after post.

    IF i leave the xp pro disc in the cd-rom drive, and do not boot from it, my system will then finish posting and boot as normal.

    I have tried recovery console:

    chkdsk /p

    In that order no avail.

    I also flashed my motherboard bios (asus m2n4-sli). To no avail.

    I am thinking my HDD is not saving the MBR for some strange reason, and before i replace it, i would like to hear your views.

  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Couldn't this be a disc fault
    Have you confirmed the disc works in another computer ?

    Check if the CD/DVD drive jumper is set to Master or Slave or Cable Select
    I have seen issues before when Cable Select works and systems that Master works - very strange I know.
    You may need to check Hard Drive as well

    Also confirm the data cable for Hard Drive and CD/DVD is in the correct order.
  3. grimesy69

    grimesy69 TS Rookie Topic Starter Posts: 52

    The Disc works fine. I am a systems technician and use the disc at least 3 to 4 times a week.

    The Jumper settings are definitely in the correct seating arrangements.

    Nothing Hardware wise has changed in my rig for about 2 months.

  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    OK another option

    It is possible the CD\DVD Drive has a fault, where reading discs in Windows works, but booting (reading first sectors) of the disc doesn't work.

    I'd suspect you would have another CD\DVD Drive that you could mount and confirm
  5. grimesy69

    grimesy69 TS Rookie Topic Starter Posts: 52

    even with the cd drive disabled in any boot order. still the same.

  6. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    And post #4 ?
    Another drive
  7. grimesy69

    grimesy69 TS Rookie Topic Starter Posts: 52

    i will try later on today, i will let you know the outcome. Thanks for your help.
  8. Eddy Rassy

    Eddy Rassy TS Rookie Posts: 69

    Have you tried resetting the BIOS to factory default. This may help.
  9. grimesy69

    grimesy69 TS Rookie Topic Starter Posts: 52

    No i have only tried flashing to the latest revision, i don't think there is any option to restore to factory default, however i will take a look.

  10. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    Replace the hard drive
  11. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    back up data
    reformat drive
    may have lost boot as system
    did you have another drive removed before this started
    when installing any new MS OS only have 1 drive in it that has no pre-formatted partitions
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...