IPX Networking Problem on Win XP for playing Red Alert 2

By krikos
Jun 17, 2005
Topic Status:
Not open for further replies.
  1. I am trying to connect two PCs running Win XP (SP2) using a crossover cable in order to play Command and Conquer - Red Alert 2 over IPX protocol. I have IP1: 192.168.123.1 and IP2: 192.168.123.2, subnet mask 255.255.255.0 and nothing set for gateway and DNS. I also disabled the windows firewall in both PCs.

    When I try to play the game I select network game in Red Alert 2 in both PCs. The problem is that in one of the PCs I see both the local player and the remote player, while on the other PC I only see the local player. The PC where the two players appear has two options, to start a new game or join a game while the other PC has only the join option. But I cannot start a new game because in the first PC I get a message saying "Only one player?".

    krikos

    :bounce:
  2. mikescorpio81

    mikescorpio81 Newcomer, in training Posts: 574

    Wierd ...

    U checked that both ur pc's aren't conflicting in some ways? like computer name or IP address ... check ur gateway too ... set them both to 192.168.1.0.

    If its not the network settings its something to do with the game maybe ...
  3. melting_ice21

    melting_ice21 Newcomer, in training

    sorry i am new and i join in at jan 2007. but i find this postreply as so non technical. as IPX protocol does not even use IP addresses to communicate. and you do not have IP based network game option in RA2. so what ever you do with IP changes..it wont work . have any other opinion people ? coz i am also facing same issue. i cannot play RA2 on LAN using IPX. i played it long back now it does not work. anyone got a clue why ?
  4. mikescorpio81

    mikescorpio81 Newcomer, in training Posts: 574

    If it is not IP related, do you think it may be something like WIN XP "simple file sharing" being enabled?
    Couldn't you work around this problem by setting up a makeshift LAN (router - switch - PCs off switch)?
    Im sorry if my previous post didn't help at all ... to be honest I didn't really take note of the IPX protocol. My bad ...
  5. Vindicare

    Vindicare Newcomer, in training

    not sure if u will get this message, just joind but i know the problem, as you were saying its not an ip problem instead you need to change your ipx address, i changed mine from 00000000 to 00000001 and it worked fine with my two machines
  6. jobeard

    jobeard TS Ambassador Posts: 13,286   +281

    whenever you couple system-a to system-b and have NOT intent to
    access the internet,


    you use a cross-over cable,
    for both systems

    ignore the DNS settings
    use a simple mask 255.255.255.0
    and on system A
    set the IP address 192.168.0.10
    and the gateway address 192.168.0.20

    and on system B
    set the IP address 192.168.0.20
    and the gateway address 192.168.0.10

    NOTICE the gateway on A points to the B system and conversely


    The ONE player issue is related to the game itself, not the networking.

    edit:
    btw: don't add the IPX protocol to the TCP stack. Instead, use the option
    of IPX over Tcp as recommened by Microsoft.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.