IPX/SPX networking problem on W2K

By dtaverner
Nov 17, 2004
Topic Status:
Not open for further replies.
  1. HI,
    Im trying to set up IPX protocol on a home network of 3 PCs. One hasW2Kserver the other 2 have W2Kpro.
    I have installed the protocol via My network places/properties on all 3 machines, and I have defined the frame type of 802.3. I have further defined the internal and the external network numbers. All to 00000000 for the time being. I found that the 2 workstations can communicate correctly (Using dxdiag to test the connection) but the server will not. I then found after reading the MS documentation that the W2K server will not accept an all zero internal network number, so I changed it to 00000001 and the workstations, as I read that the network numbers must all be the same (although its not clear if that should be the internal network number or the external or both)
    The server still does not connect with the others. :bounce:

    Any ideas? I must have missed some parameter, and after reading Jasons article Im still not clear where the fault lies. for W2K server to communicate with W2K pro.

    Is this a WINS issue? or NetBIOS?
    Thanks in advance for any assistance
    DT

    BTW..all machines communicate fine via TCP/IP and normal file and print sharing is achieved. One bog standard ethernet NIC on each machine. They are linked via a 3com router, which also gives adsl internet access. The server has DHCP and DNS forwarding activated (standard Active Directory installation I think!)
  2. RealBlackStuff

    RealBlackStuff Newcomer, in training Posts: 8,165

    Welcome to TechSpot

    What do you need that extra IPX protocol for? Are you using a Novell Netware network? If not, you don't need it. The more protocols, the slower the connection.

    A few basic setups when networking:

    Router-setup WAN:
    Protocol: Fixed IP
    IP-address, Subnetmask and default Gateway: as per ISP-information
    DNS-servers: as per ISP-information
    Enable NAT

    Router-setup LAN:
    IP-address: set to e.g. 192.168.1.254 (or use default)
    Subnetmask: 255.255.255.0
    DHCP-server: disable

    Router: Some System-settings (depending on your router)
    Optional SNTP (time): e.g. 194.35.252.7 for UK/Ireland (GMT)
    uPnP: disable
    Dynamic routing: disable
    Remote config: disable
    Dynamic DNS: disable
    Firewall: Block hacker attack: enable
    Firewall: Block WAN request: enable
    VPN: disable all settings unless you need it

    PC-Settings
    Internet Protocol (TCP/IP)
    Use the following IP address: 192.168.1.101 (102, 103 etc.)
    Subnetmask: 255.255.255.0
    Default Gateway: 192.168.1.254 (IP-address from your Router)
    Use DNS Server address: 192.168.1.254 (IP-address from your Router)
    Second DNS: leave blank or put in first DNS-server from WAN-part in Router

    Enable File/Printer sharing if you wish (works only within local network)
    Check individual printer(s) that they are shared as well (in printer-settings)

    And make sure all your PCs are in the same WORKGROUP.

    If software firewall installed, enable the other PCs IP-address(es)
  3. dtaverner

    dtaverner Newcomer, in training Topic Starter

    Thanks

    Thanks
    My TCP/IP LAN and internet access are fine. I need to use the IPX/SPX protocol.
    Please refer to the oroginal question.
  4. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    If you are using Compatibilty Mode drivers , i understand the server will default to FFFFFFFD and the Clients must match .
    ,I use IPX/SPX on my Lan but in a Workgroup , so my settings are different.I have 00000005 on each computer.HMMM!

    Wins should not be involved at all.
  5. Electrick Gypsy

    Electrick Gypsy Newcomer, in training Posts: 89

    There are a few very good networking bilbes available as e-books on the web if you're interested.
  6. dtaverner

    dtaverner Newcomer, in training Topic Starter

    Thanks Liquidlen,
    It seems that the server will assign itself a random internal number anytime if it is set to an all zero number.
    what I dont yet understand is the requirements re internal network number vs external.

    I have tried setting all the internal numbers of the 3 machines to the same, and all the external numbers the same (but different from the internal) and all the same internal and external. with the same frame type on all machines.
    Still doesnt work.
    The only bit that works is between the two workstations when they are set to all zeros both internal and external.
  7. dtaverner

    dtaverner Newcomer, in training Topic Starter

    If you know of one that deals with IPX/SPX on windows 2000 server, that would be great.
    cheers
    DT
  8. RealBlackStuff

    RealBlackStuff Newcomer, in training Posts: 8,165

  9. dtaverner

    dtaverner Newcomer, in training Topic Starter

    thanks, Ive been googling for a week now over this, but I hadn't yet come across this, which looks quite promising. (I think most of the hits are my posts!) :haha:
  10. dtaverner

    dtaverner Newcomer, in training Topic Starter

    I'VE FIXED IT!
    In case you're interested, the answer was to DISable Routing and remote Access Service in Active Directory
    Works like a charm!
    thanks for your help anyway
    :giddy:
  11. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    dta...
    Thanks for posting the answer you found.
    If you get a chance could you also post what the 'internal numbers' ended up being.Great for a cross reference.
    Glad it worked out ,see you around.
  12. dtaverner

    dtaverner Newcomer, in training Topic Starter

    To summarise, the internal network number can be any 8 digit hexadecimal number. The default is 00000000 which is fine on W2Kpro but not accepted ny W2K server or NT server. when a connection is established on a server, the server automatically generates itself an 8 digit random number. Its fine to leave this.
    The external number should be set to a common number for all machines trying to communicate. the default again is 00000000, but anything will do, as long as all machines are the same. Lastly, the frame type should be set to 802.3 on all machines according to westwood.
    However, I also found that if you set the external number and frame type to Autodetect (available in W2K/NT4/XP), it also works.
    RRAS in Active Directory must be disabled. So if you have a VPN and connect to your home network from another location using this method, it wont work while RRAS is turned off!

    I now consider myself a Guru on Red Alert 2 networking issues! :giddy:
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.