TechSpot

Javascript

By circusboy01
May 4, 2013
Post New Reply
  1. As usual I hope this is the correct forum for this.I brought my computer back to factory setting.. I've seen, more than once, that it is good to do that once in a while. Besides I was bored.
    Here's my problem I shut off Javascript, because of all the bad stuff I have been hearing about Java. Now I'm thinking Java, and Javascript are 2 different things. Because every time I turn around something wont run because I don't have Javascript.
    Can someone please tell me how to reinstall Javascript.? The instructions I get are no help. for instance Google says click on wrench.and select prefferences. There is no wrench to click on, and no prefferences anywhere, that I can find
    I'm using IE, Google Chrome, and Firefox. So I guess I need it turned back on in all of them.
    Thanks in advance for your help.
     
  2. jobeard

    jobeard TS Ambassador Posts: 13,516   +336

    Java is not Javascript.

    Java needs to be downloaded and installed.

    Every browser supports Javascript and the user can enable / disable it via the browser settings.

    a) do not install Java
    b) enable Javascript

    :)
     
  3. circusboy01

    circusboy01 TS Enthusiast Topic Starter Posts: 892   +12

    Thank you. Where are the Browser setting?
     
  4. cliffordcooley

    cliffordcooley TechSpot Paladin Posts: 6,401   +1,591

    You should be able to turn Javascript back on, in the same place you turned it off.
     
  5. circusboy01

    circusboy01 TS Enthusiast Topic Starter Posts: 892   +12

    That makes sense. I even thought of it myself. Trouble is I don't remember where or how I did it.
    No problem though. I just typed how do I enable Javascript in Mozilla Firefox in the search window, and followed the instructions.
    Was going to do the same thing in Google Chrome. Then I saw what looked like a little open box with a little red mark. I clicked on it and it said my Javascript was disabled, and provided a place that I could click on to turn it back on.
    Don't really care if it's on or off in IE. Never use it
    Guess I should have tried harder to figure it out myself before I bothered you guys. Sorry ;0)
     
  6. TheDreams

    TheDreams TS Booster Posts: 565   +47

    No offense but you made me laugh today haha, I almost died!:p
     
  7. _Vikas_Chauhan

    _Vikas_Chauhan TS Rookie

    I use Mozilla firefox. And in this u can enable it by following steps:
    1. Go to Tools option at top of firefox before Help tab.
    2. Click Tools and then Options (its the last drop down option in Tools.).
    3. Go to Content Tab in the Options Menu.(Its the third tab at top of Options Menu.) Click on it.
    4. Check Enable JavaScript if its disable. That's it. I hope I have conveyed it properly.
     
  8. Darth Shiv

    Darth Shiv TS Evangelist Posts: 1,184   +177

    If it is enabled, you may have installed an addon in Firefox such as NoScript that is blocking javascript on sites by default.
     
  9. learninmypc

    learninmypc TS Evangelist Posts: 5,448   +242

    Ok, you don't need java (IMHO) so to get to settings in Google Chrome, click the 3 horizontal bars upper rignt & click setting in that menu.
    Go down & click on Show advanced settings & locate Privacy & click on Content Settings. You'll see the Java Script settings. Good luck.
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.