TechSpot

Keyboard Issues

By Vehementi
Feb 24, 2002
  1. I'm having problems with a keyboard on a different system than this - It's an ABit BH-6 with a Pentium 3 550. The keyboard simply will not work. I tried it on this system and it works fine. It's completely dead - not even the caps, scroll and num lock lights work. Yes, it is plugged in. Are the PS/2 ports on my system board not working? A simple PS/2 - USB adapter will fix this. Is it something in the keyboard that makes it uncompatible with the board? It's not a device problem in Windows - I can't use it outside of it either (Like hitting del to enter my CMOS). Anyone have this same problem??
     
  2. MrGaribaldi

    MrGaribaldi TechSpot Ambassador Posts: 2,512

    Sounds very much like a dead ps/2 port to me...
    If it had been something else, you should've noticed it when you switched the keyboard from one 'puter to another.... (BTW: you did test with another keyboard on the BH-6?)
     
  3. MrGaribaldi

    MrGaribaldi TechSpot Ambassador Posts: 2,512

    Re: Re: Keyboard Issues

    Though there is one thing I find a bit odd... You didn't mention any errormessages, and you should get one right after memory check...

    But this just seem to confirm the faulty Ps/2 port, as it finds the keyboard, but won't give it the power it needs...

    oh, well...

    .02$
     
  4. Vehementi

    Vehementi TechSpot Paladin Topic Starter Posts: 2,704

    No error messages - nothing out of the ordinary. Boot up is perfectly normal.
    I tried a different keyboard on it...to no avail.
    PS/2 ports are dead then...
     
  5. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +6

    you might be lucky to get a PCI card with PS2 ports.... then you could use that....
     
  6. ToRN

    ToRN TS Rookie Posts: 156

    PSU

    I had a similar problem. After 3 days of switching everything, I found the cause.

    My PSU was bad, so there was some magnetic interferance and therefore my keyboard didn't work. I replaced the PSU and everything was OK.
     
  7. Vehementi

    Vehementi TechSpot Paladin Topic Starter Posts: 2,704

    I only replaced my sysbo, CPU and RAM. No change in PSU whatsoever...my keyboard isn't even closer to my tower.
    Besides, not even my mouse works in the PS/2 ports (it's USB).
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...