LAN connection with Router problem... * had this for years... a little help please?

By osmarsmith
Dec 12, 2004
  1. Ok...... I'm kevin.
    I have 2 computers at home, and they're both XP SP1, pentium4.
    One of the computers have D-link DFE-530tx pci fast Ethernet adapter (rev .b) and the other one has realtek RTL8139 family PCI fast Ethernet NIC.

    when I type ipconfig/all in dos, the following info shows up
    (This one is the comp with D-link)

    Host Name . . . . . . . . . . . . : privite-jypsard
    Primary Dns Suffix . . . . . . . : (it is blank)
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet Adapter:
    Connection-specific DNS Suffix . : Domain
    Description . . . . . . . . . . . : MAC Bridge Miniport
    Physical Address. . . . . . . . . : B2-13-56-11-A5-93
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . :
    Subnet Mask . . . . . . . . . . . :
    Default Gateway . . . . . . . . . :
    DHCP Server . . . . . . . . . . . :
    DNS Servers . . . . . . . . . . . :

    I have Road runner cable service, and I have a Router to connect to the internet. My router is AboCom CAS2047, and both computers can connect to the internet. I have set both computers to the same workgroup, but they do not appear in "My network connections". (They're suppose to when they're LAN connected, right?) I tried to search for the other computer on both computers, but only one of them can find the other one (that one is the one using D-link). My main goal is to be able to PLAY Lan games, cuz that's what all my friends asks me if my computer can do that. I know I might be a little bothering, but I always wanted to fix this for years... please help me, thanks a lot...

    *additional information:
    the ipconfig/all stuff for the OTHER computer is:
    (it's blank if nothing is there)

    Host Name . . . . . . . . . . . . : com2
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : Yes
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : MAC Bridge Miniport
    Physical Address. . . . . . . . . : 02-43-82-D4-C9-63
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . :
    Subnet Mask . . . . . . . . . . . :
    Default Gateway . . . . . . . . . :

    Connection-specific DNS Suffix . : Domain
    Description . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Ethernet NIC

    Physical Address. . . . . . . . . : 00-50-FC-63-86-EC
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . :
    Subnet Mask . . . . . . . . . . . :
    Default Gateway . . . . . . . . . :
    DHCP Server . . . . . . . . . . . :
    DNS Servers . . . . . . . . . . . :

    *more additional information:
    For some awkward reason, I have:

    Local area connection
    1394 connection
    A Bridge of some type

    in my internet connection
    (My computer is not in English, that's what it says if translated)
    same with the other computer.

    I would reinstall both of my computers if necessary, My internet connection might change because of that... someone had messed with it and it still works... I'm not sure what it will be if I do reinstall it.

    What I'm trying to do is to establish LAN connection. I dont really know how to do the settings, I've tried a couple ways my friend told me, but didn't work, one of them even caused a severe system crash.

    If more additional info is needed, please state, I will reply as soon as possible. Thanks SO much.
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  3. osmarsmith

    osmarsmith TS Rookie Topic Starter

    I did try searching, I have came up with that information too, but I do not know how to change the settings... it doesn't seemed to be explained.
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    For the router-changes, see your manual.

    The other changes can be made when you go to Start/Settings/Network...
    Rightclick Local Area Network, select Properties, then select Internet Protocol (TCP/IP). Now click on button Properties, where you find IP/gateway/DNS atc.
  5. osmarsmith

    osmarsmith TS Rookie Topic Starter

    I dont seem to be able disable DHCP-server, the setting in my router.
    I go to to change my router settings, I do find DHCP-server, but once I disable it, I no longer have internet connection. I could not connect to either, I had to reset router to factory settings.

    What happens now it that I have set (tcp/ip) for both computers to the specified txt above, and I also disabled DHCP-server. However, only one computer can use the internet after that.
    I do not have Optional SNTP (time),uPnP,Dynamic routing,Remote config,Dynamic DNS options in my router. It does not have NAT option either. There are no options for that. (I do not know if they are enabled or disabled either...)
    Do I need to get another Router?
  6. osmarsmith

    osmarsmith TS Rookie Topic Starter

    After a couple of tries, I managed to make both computers able to use the internet. However, the other computer doesn't appear in My naborhood. They are in the same work group, I also tried to search for the other computer's computer name. I couldn't find it either. Could it be because I dont have the options in the router? Thanks... :wave:
  7. The Best Alias

    The Best Alias TS Rookie Posts: 113

    You do have file and print sharing for micro$oft networks enabled on both machines ....... don't you?
  8. osmarsmith

    osmarsmith TS Rookie Topic Starter

    Yes I do, both machines. I have also activated printer sharing at the local printer settings.
  9. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    If you don't have NAT, you must keep DHCP enabled and set your PCs to "obtain an IP automatically".
  10. osmarsmith

    osmarsmith TS Rookie Topic Starter

    Ok, now I have changed both computer's settings to the specified above. (DCHP enabled, and auto find ip)
    If I want the two computers to be able to make lan connections, I should be able to find the other computer by searching for computer, and typing the computer name, that's in the same workgroup. I do have both computers in the same workgroup, however I can only find computer B with computer A, but can't find computer A with computer B. It doesn't respond at all though when I try to ping computer B with computer A (I ping comp. B's address, right now it's I tried pinging all other ones, but none would work (other than the own computer's address, and, which is the router)
    well, seems really complicated..... if it's way too complicated, I'll just probably get another router.....
    sould I?
  11. HoopaJoop

    HoopaJoop TS Rookie Posts: 90

    1) If that router has a switch on it, or if you are using a switch, you shouldn't have any bridged connections in your machines.

    2)Do you have any firewalls on the machines? Some firewalls automatically disable ICMP access. This will make it impossible to ping.

    3)Be certain that you don't have ip addresses keyed in on the adapter's TCP/IP settings. Then, from each machine, ping the other machine's IP address. If you can ping the address but not the hostname then you are having a name resolution (DNS) issue. You can work around that using host the files. Look in the lmhost.sam file for further instructions. You really shouldn't have to do that though.
  12. osmarsmith

    osmarsmith TS Rookie Topic Starter

    The only swich (actually button) on my router is the reset switch. I believe that means I'm not supose to have bridge on my computer. Very awkwardly, I have them on both computers. They've been there for a very long time. I do have firewalls too, however I have tried to ping them with firewall disabled (didn't work). I'm guessing it's because of my bridge problem that's preventing me from making LAN connections. I can't disable the bridge though, if I disable it I can't use the internet.
    The things that are in my internet connections are:
    local area connection
    1394 connection
    internet Bridge
    (my com's not english, they're translated)

    I can't seem to find some info on the net to turn off bridge though, I've checked some friend's computer and it doesn't have brige at all. I can't just delete it, or else I can't use the internet.
    How do I turn off bridge?

    (looks like problem's getting clearer....)
    thanks to all the people that helped me so far...
  13. HoopaJoop

    HoopaJoop TS Rookie Posts: 90

    I'm sorry I should have clarified what I meant by switch.

    When I said switch I meant the device that filters and forwards data packets. You may have a hub instead of a switch. While there is a vast difference between the two, for the average home user these devices perform the same function. Essentially, when you have a multiple machines that you want to connect together on an ethernet network a switch is the device that connects them on the physical layer. This is the device that you plug your machines into. This is also regardless of your internet connection. A switch creates your LAN, and a Router translates your lan traffic to allow you to access the internet.

    On a standard home use broadband routers there are 2 RJ45 (like a phone cable but bigger with 4 pairs) connections. One, usually labeled 'WAN', is for your internet connection. This one plugs into your DSL/Cable modem. The other line is for your LAN. If you have only one machine to connect to the internet you connect it directly to this port. In your case, you would need the switch/hub to provide you with more ports for more devices.

    Some Routers have switches/hubs built into them. You'll notice these by their multitude of ethernet ports (usually 5 on home models). Often times with switches and hubs (ones that are separate from the router) one of the ports is reserved for the uplink. The uplink port is where you would have to plug in an ethernet cable connected to the Lan port on your router.

    So I guess my question is really: Do you have a separate switch/hub or is it built into the router?

    Typically if you are using a switch/hub you do not need to bridge connections. Especially since you are running your network on one subnet. The only reason I can think of is if you have the router emulating the mac address of one of your nics. Still though, I don't think you'd need a bridge for that.

    Cancelling bridged connections is different per OS. What OS are you running?

    I'll explain the difference between a switch, and a hub if you like, but I feel I've rambled enough. And that can become a really long conversation.

    Also, I'm not sure if you changed them, but you shouldn't post your actual IPs on the internet. Even though those IPs are private and cannot traverse the internet, one important piece of info to have when breaking into a network is the subnet. If one can get the IPs of specific machines then you are even further. Just a word of warning. Often times people use letters for the 3rd and 4th octet. This still narrows it down, but to a more negligable 65,534 possible hosts.
  14. osmarsmith

    osmarsmith TS Rookie Topic Starter

    my OS is XP sp1. I believe I didn't post my actual ip address. 192.168.1.*** are all just local addresses, and apply to many computers that has routers. I don't think I have a separate switch/hub. my internet cables run out of my computers, into the router, and then one cable connecting the router to the little cable box. my problem right now is that I can't disable my bridge. if I disable it, I can't use the internet. My computers did not have bridge before, I probably did something that made it pop up. how do I disable it?
  15. HoopaJoop

    HoopaJoop TS Rookie Posts: 90

    You should be able to right click it and disable it. There should be an option to do so.

    Yes those are internal, and cannot be routed on the internet, but were I wanting to get on your lan, that is one of the usefull bits of info i'd like.
  16. osmarsmith

    osmarsmith TS Rookie Topic Starter

    I do have that option, but if I disable it I can't use the internet
  17. HoopaJoop

    HoopaJoop TS Rookie Posts: 90

    If you know how to re-enable it then you may want to try this:

    1)Disable the bridge
    2)right click the interface you connect to the router with and select 'repair'
    3)Run an IP config to check for a valid IP

    Neither of your computers should have bridged connections if your computers are plugged into a hub or switch on your router.
  18. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    From what I found on the internet, you need Firmware version 1.5 or higher to properly connect to the internet with your router.
    Also, make sure you set ALL the settings identical in each PC, with the exception of the (fixed) IP.
    If your current setup still is as messed up as in your first post, I'm not surprised it does not work.
  19. raadeekaa

    raadeekaa TS Rookie

    My LAN n Internet

    Hai friends,
    I read all ur posts , but yet i don't understand what u say.. I have 2 computers at home..all r connected thru i want to share my internet(Broadband) among them.. Itrie dby hooking the internet cable to the hub..n i changed the ip address of all the computers as says a conflict..I think i have made a mistake.. What are steps should i do to share my interet..
    Iam an amateur in this kindly tell me in easy way..sorry for giving u trouble.
    With thanx in advance,
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...