TechSpot

Language Support

By sbruce45
Mar 7, 2007
Topic Status:
Not open for further replies.
  1. I am using XP SP2. I added a second language for keyboard entry via the Regional and Language Options entry of the Control Panel. Even though I set it to English, the date (month, day) appears in the other language. This appears in every program that shows the day and month, including the clock on the system tray.

    Does anyone know if this is justa quirk in XP, or if there is some way to correct this?

    Thanks,

    Bruce
     
  2. mikescorpio81

    mikescorpio81 TS Rookie Posts: 574

    Change your timezone settings to wherever you are. Double-click the clock in the bottom right-hand corner of the taskbar (navigation pane I think it is called btw!) and set your timezone correctly.
     
  3. sbruce45

    sbruce45 TS Rookie Topic Starter

    My time zone is correct, and it has not changed after adding the second language

    Bruce
     
  4. mikescorpio81

    mikescorpio81 TS Rookie Posts: 574

    OK, where did you make changes in regional and language settings? If you wanted to add a secondary keyboard language, the only place you should have made this change is Control Panel - Regional and Language Options - Languages Tab - Advanced - Settings Tab - "Add". Then under preferences you should show language bar on desktop (if its not already there).

    If you changed anything else, you now have to go through all regional and language options settings and change them back. There are a few places whereby you can specify where you are within this option.
     
  5. sbruce45

    sbruce45 TS Rookie Topic Starter

    That is where I made the change. Under Advanced, English is shown as the Language for non-Unicode programs. The other language is a right-to-left language and 'install files for complex script and right-to-left languages' is also checked. I do get the language bar, and it changes with the use of ALT-SHIFT, as does the language obtained via the keyboard.

    Mike,

    It appears that I've fixed the problem. I undid the changes and then re-did them. But this time I did the right-to-left change first and restarted system. Then I selected the language. Last time I selected the language first. Thanks for your advice.

    Bruce
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.