TechSpot

Lexmark X73 problems

By arpa
Jan 26, 2004
  1. I HAVE A LEXMARK X73 PRINTER CONNECTED TO A DELL COMPUTER. I WAS TRYING TO PRINT WHEN I RECEIVED A MESSAGE THAT SAID 'PROBLEMS COMMUNICATING WITH THE PRINTER'. MY LEXMARK X73 HAS THE STATUS LIGHT FLASHING ON IT. EVERYTHING IS CONNECTED PROPERLY AND IT IS MY DEFAULT PRINTER. I CANNOT GET ANYTHING TO PRINT. DO YOU KNOW WHY?
     
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Firstly, welcome to Techspot.
    Secondly, please use normal print, not all capitals.
    Thirdly, check the manual/Help in the troubleshoot-section. You may have run out of paper, ink/toner, or a piece of paper might have got stuck inside.
    See if a Reset or Power Off/On of the printer gets it going again.
     
  3. caledonwind

    caledonwind TS Rookie

    lexmark x73

    I am encountering the exact same problem with my x73. Worked fine over the past year until last week. Prints test pages, so no problems with ink, paper, etc. I disconnected the printer and uninstalled the software and setup all over again. Same problem comes up "problem communicating with the printer" Any other suggestions?
     
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  5. Mister K

    Mister K TS Rookie

    Here is the only worthwhile solution: take the machine, open your window, and throw it out. I have had innumerable problems with the X73. After six weeks of reinstalling system software over and over again in an attempt to cure the incredible lack of speed I was experiencing a friend found that the X73 driver was leaking resources and using up to 99% of the CPU every three seconds even when not in use. The only cure was to open terminal and run top to find the process number and kill the process everytime I had used the machine. Not worth it. One time the Scan and Copy app could not be killed even from terminal and I had to shut down my mac. (which is usually impossible to crash) And support? A very rude, sarcastic and unhelpful reply to the unfeasibly lengthy "support" form I had to fill out. Even their website is full of bugs and 404s. I will never buy Lexmark again, and I would advise everybody to do likewise.
     
  6. southtown43701

    southtown43701 TS Rookie

    lexfarts

    this will work, did for me, remove x73 from add/remove programs, at lexmark run the clean uninstall utility, reboot, search for anything lexmark,delete, reboot, go to lexmark and run the patch 1st, then drivers, this is the only way it works, if patched after driver install it dont work, i have done this 10 times, always works, Lexmark x73 are junk still.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...