TechSpot

Limited or no Connectivity - Please Help!

By Thalin
Nov 10, 2004
  1. I have recently attracted the annoying message, Limited or no Connectivity, on my internet network connection. I heard it was a problem/bug with SP2, and I am looking for an answer.

    My internet works, however, we are on a network, and it's the other PC which can't connect.

    I have a Local Area Connection, which I use to connect to the internet.

    I have a connection which is my network card, used to link the 2 PCs on the network. Sometimes, I am getting the message on my side to.

    Usually, I go into network connections on the other machine, which is on the network, configure the network, and another connection icon will appear saying Local Area Connetion on John (my machine), which is normal. This then lets us both use the internet on the network.

    I do not use a router, just a wire going from my PC to the other one.

    I have tried everything. The Windows SP2 patch, another one which is something to do with clearing all the TCP/IP Stack, and that does nothing. I have also tried uninstalling SP2 but to no availl. I have ran these programs on both PC's, and have had no luck.

    I don't seem to be getting the limited or no connectivity icon as much, since I reinstalled SP2, I just can't get the network icon to appear on the other machine, showing it has connected to my PC through the network, after configuring the home and networking wizard with Windows.

    Any help would be greatly appreciated.
     
  2. Thalin

    Thalin TS Rookie Topic Starter Posts: 103

    Please help.
     
  3. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 8,165

  4. Emilio Trampuz

    Emilio Trampuz TS Rookie

    Solution to "Limited or no connectivity" in SP2

    I had the same problem with "Limited or no connectivity" right after I installed Windows XP - Service PAck 2. I tried all the suggestions found in various forums, as well as in Microsoft's Knowledge Base. Nothing worked. Nothing is wrong with my network. My NIC card works just fine. But, there is a basic problem with SP2 itself, ... and the Windows update doesn't do anything to fix it.

    After wasting almost a week on this problem, and having to live without my printers and without my network, ... I finally decided to quit wasting my time. Instead, I tried the only solution that worked before, ... and sure enough, it worked again.

    Here's what to do:

    1. UNINSTALL Windows XP -SP2.
    =============================
    Go to Start - Settings - Control Panel - Add/Remove programs. Highlight the line that says "Windows XP Service Pack 2", and click on the REMOVE button. The removal will take about 10 minutes, after which you will have to reboot the computer. Presto! Everything works again! My printers are back! My network is back!

    I can finally be productive again, instead of struggling with Windows problems caused by Windows itself!

    All of the other suggested "solutions" won't help because there is some evil code embedded in SP2. Get rid of SP2, and everything will work again! I guarantee it.

    I did this twice. Every time I install SP2, I lose my printers and my network. Every time I uninstall SP2, I get everything back. SP2 is the culprit. Get rid of it. It's time for Microsoft to admit it has a serious flaw in SP2.

    2. DISABLE AUTOMATIC WINDOWS UPDATES
    ========================================
    If you have enabled automatic updates, SP2 will try to re-install itself. The only way to prevent this is to disable automatic Windows updates. Instead, do the updates manually, say once a week or so, and be selective. Don't download anything that has remotely to do with SP2.

    To turn off automatic updates, go to Start - Settings - Control Panel - Automatic updates. Then simply place a dot in front of the option to turn off automatic updates. Done! Now you can sleep in peace!

    Don't worry about the warning that says your computer might be less secure if you turn off automatic updates. You'll be perfectly safe if you do manual updates from time to time. Just stay away from SP2. It will do more damage to your system than any hacker has ever caused.

    Better yet, maybe it's time to start thinking about Linux instead of Windows. That Linux penguin seems more attractive every day!

    I am also planning to stop using Microsoft Internet Explorer and Outlook Express. Instead, I'll switch to Firefox and Thunderbird.

    Now, if only there was a way to get this message through to Microsoft's decision makers!

    Sincerely,

    Emilio Trampuz
     
  5. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 8,165

    Your message is like beating a dead horse. Everybode curses and swears at SP2.
    I never installed XP to begin with, and never will. Stay with the rock-solid Windows 2000 Pro, it's what I've been running for years. My current install is from somewhere in 2003!
    No crashes, no BSODs. Been using Firefox and T'bird without any problems.
    Use IE exclusively for Windoze-updates, and you're fine.
     
  6. Emilio Trampuz

    Emilio Trampuz TS Rookie

    Thanks for the support

    Hey Realblackstuff!

    I totally agree with you. I was just hoping to warn others not to waste their time with SP2. I spent almost a week trying out the various "fixes" people have suggested. The only fix that worked for me was to get rid of SP2. And that worked like magic!

    I just wish I had found your opinon of SP2 before I went through all this trouble. Similarly, I am hoping that someone will find my statement about SP2 before they waste too much of their time.

    Glad to hear you like Firefox and Thunderbird. And, yes, I understand that Microsoft is being childish by insisting that we use IE when we contact them for updates.

    Emilio
     
  7. Lukeywarthead

    Lukeywarthead TS Rookie

    'Limited or No Connectivity' FIX

    Go to a command prompt window (start > run, then type CMD and hit 'OK') and type the following command:

    netsh winsock reset catalog <<and then hit enter>>

    It will then tell you that the winsock catalog has been reset and all sockets flushed, etc. - it then will to ask you to restart the PC. Restart the PC and you should be pulling a valid IP address again.

    Also, for other issues related to XP's Service Pack 2, Microsoft has setup a free hotline for support. The number is: 1-888-SP2-HELP. Hope this helps!!!
    :hotbounce
     
  8. dabomb9306

    dabomb9306 TS Rookie

    Sp2

    I say screw SP2. Censor that if you must, but still! I've had nothing but problems with SP2 ever since I installed it!!! :dead: :mad:
     
  9. The Guru

    The Guru TS Rookie

  10. jobeard

    jobeard TS Ambassador Posts: 13,517   +336

    use caution

    To reformat a HD or reinstall the OS as a means to solve a specific problem,
    especially networking is a knee jerk reaction and overkill which will clearly cost
    you signficant time, effort and loss of your personal files. Personally, I always
    feel that I've failed to do sufficient homework whenever I am reduced to this
    as a solution.

    In rare cases, it may be the shortest time to get things running, but you will
    STILL be faced with the problem of getting the configuration right --
    which was the initial issue you started with!

    You are clearly connecting two pcs using a crossover cable and need ICS to
    be enabled. The ability of the second pc to acquire an IP address that does
    NOT start with 169..... (the cause of your limited connectivity msg) is
    dependent upon the ICS service.

    see this tutorial to get ICS running
     
  11. The Guru

    The Guru TS Rookie

    1. Click Start, click Run, type "ncpa.cpl" (without the quotation marks) and press Enter.

    2. Right-click the connection with an overlaid yellow symbol and click Properties.

    3. Click on the "General" tab, highlight "Internet Protocol (TCP/IP)", and click Properties.

    4. Click on the "Alternative Configuration" tab, select the "User configured" radio box.

    5. Type 192.168.0.2 in the "IP Address" field.

    6. Type 255.255.255.0 in the "Subnet mask" field.

    7. Click OK twice.
     
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.