TechSpot

Logitech headset problem

By haseebcash4u
Jan 20, 2007
Topic Status:
Not open for further replies.
  1. darel001

    darel001 TS Rookie Posts: 62

    Hope this helps, go to start,programs,accessories,entertainment,volume controll, then click file>>properties>> select input properties>> and then check microphone and click ok. Now go back to regular audio properties, make sure mic is not mute and then raise all the volume. Try to check if its working by trying to record something in the widows sound recorder.(same steps except instead of pressing volume controll u press sound recorder).

    Now if this doesnt work, go to control panel, switch to classic mode if using xp ,click on an audio icon ( not the SOUND AND DEVICES ICON!), although that might be the only one u see. But if there is a different icon click it, (in my case its called Realtek HD soud....) now if its like mine, go to: MIXER tab>>> click the two little dots (maybe the options icon on the mic area) and select MICROPHONE BOOSTER. TRY TO FIND THE MIC BOOSTER.

    Well hope this wasnt too confusing and that it does help.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.