Losing hair over DVD drive

By Queerest
Mar 24, 2006
Topic Status:
Not open for further replies.
  1. I am having a problem with my Aopen DVD/RW drive. While audio cds work fine, it simply fail to read dvds. It was working just fine before. However after I reformatted my computer recently, I have not been playing any dvds so I don't have any clue when the problem started. Plus to add to this confusion, I am able to watch Shrek2 DVD and 3 other DVD-Rs (which I've burned before). All other DVD movies I have and my SIMS 2 DVD game are not detected. When inserted, the green/yellow light flashes and shortly after the DVD/RW icon changes to cd-drive. I am terribly frustrated so can anyone kindly help me with this annoying problem??
    p/s: the Sims2 DVD can be read in my friend's pc. puke:
  2. Peddant

    Peddant Newcomer, in training Posts: 1,644

    This is from here - http://www.tek-tips.com/viewthread.cfm?qid=1200044&page=1 Worth a try.


    1) Run the autofix tool:
    http://www.microsoft.com/downloads/...B6-E8FA-45C4-A171-1B389CFACDAD&displaylang=en

    2) Uninstall/reboot/reinstall Nero

    3) Remove the drive from Device Manager, shutdown, disconnect the drive and any other device (assuming this is the secondary channel) from the IDE cable. After booting back up, shutdown again (this gives Windows a chance to see that the IDE channel is empty). Reconnect the drive and turn on the PC. Go back into Device Manager and the properties for the IDE channel. Verify that it's using DMA under the Advanced Settings tab.

    4) http://support.microsoft.com/kb/321641/en-us
  3. Queerest

    Queerest Newcomer, in training Topic Starter

    I tried the autofix tool.. it didn't work. I tried the option (3)..alas I got lost! I am rather bad at computing stuff, see. Is there any way that you can interprete that option into simpler form. I am rather confused with all the secondary/ primary and master/ slave. But what I can see from my Bios setup, the AOPEN drive is in the primary IDE. I am trying hard here .. all I want to do is make my drive read DVD-rom games again.
    Thanks really for your help but I am still losing hair .. (Sinead O' Connor in the making)
  4. N3051M

    N3051M Newcomer, in training Posts: 2,800

    1. Right click [my computer>properties>Hardware tab>Device manager]
    2. scroll to your dvd/cdrom drives in the list, press the plus sign next to it to expand it.
    3. remove the drive you're having difficulty with - right click > uninstall
    4. shut down your pc.
    ---
    5. Disconnect power cohrd, and maybe everything else if needed, open up the case to your tower (usualy two screws on the back)
    6. touch the case frame to ground yourself.
    7. pull out the cables from the problem dvd drive, one is a flat ribbon type the other is the power
    7b. if it is on a seperate (ribbon) cable to a HDD, disconnect any other devices and their power source
    8. make sure no wires or pins are exposed/touching anything (tape them down temporarily if needed), reconnect the power from mains and other cables taken off and boot up.
    9. after it finishes loading, shutdown the pc again.
    ---
    10. do steps 7(b) in reverse - in other words put it back together, but make sure you ground yourself and power is taken off the system, and also step 8.
    11. when everything done, turn your pc on again.

    //windows will detect the drive and reinstall the associating drivers to make it work automaticaly.

    12. go back to device manager (how to ->step 1) and check that your dvd drive is back on the list, and there's no yellow question marks anywhere.
    13. scroll down to IDE ATA/ATAPI Controllers, expand that, find the one where your dvd drive is connected to (if its the same line as your winxp HDD, it will be on Primary IDE, if it is seperate line it would be on Secondary IDE.
    14. double click it then go to [advanced settings tab], under transfer mode, confirm if it is selected on DMA if available

    dont worry.. thats why man made tupe`s... :chef: :haha: jokes....
  5. kirock

    kirock Newcomer, in training Posts: 1,598

    Did you check the DVD Region? Device Manager/DVD drive/double click to open properties/DVD Region Tab. Make sure it is set to the approprite region. Note: There is a limit to the number of times you can change the DVD drive region.

    Just a thought.

    Cheers

    EDIT: Maybe it needs a cleaning. I know these stupid DVD/CD cleaner kits are way over priced...but! These things are not called OPTICAL drives for nothing, the laser and or detector can become dirty and then certain DVD's won't play. Each DVD or CD has it's own optical reflection variance (some are just "shinier" then others). Cheers again.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.