Low Fps With A Better Graphics Card????

By kurryman
Jul 27, 2007
Topic Status:
Not open for further replies.
  1. well i got a new AGP 512mb x1650 pro but im getting lower fps in my counter strike source before on my old card which was ati 9250 i got about 30-40 but now i get 10-30. btw i had to get a new PSU which is 400watt i did a new install of vista and latest Catalyst driveer and program i also tried the card with xp still no diffrence.

    system specs:
    intel p4 2.8
    1.2gb ram
    2 hhd 160/80
    x1650 pro
  2. tipstir

    tipstir TS Ambassador Posts: 4,576   +76

    Beef up that RAM for VISTA, but what's the specs for FPS for your GPU..
  3. kurryman

    kurryman Newcomer, in training Topic Starter

    dont know how do i find out?
  4. tipstir

    tipstir TS Ambassador Posts: 4,576   +76

    Who makes the video card or are you using onboard video on the MOBO?
  5. tipstir

    tipstir TS Ambassador Posts: 4,576   +76

  6. kurryman

    kurryman Newcomer, in training Topic Starter

    its Sapphire ATI Radeon X1650 Series
  7. kurryman

    kurryman Newcomer, in training Topic Starter

    and my mate he has a ati 1600pro, the downgraded version of mine and he still got better performance in Fps then me
  8. kpo6969

    kpo6969 TechSpot Maniac Posts: 875

    3 possible issues?
    1.What does new install of Vista mean? Clean, re-install, all drivers re-installed after the "new install"?
    2.Both of you using the same Catalyst version?
    3.PSU-how many amps on the 12v combined?

    Also, you definately need more ram. I have 3GB and Vista uses 1535mb for graphics.
  9. LinkedKube

    LinkedKube TechSpot Project Baby Posts: 4,262   +41

    Wow that's sick, Vista pulls 1.5 Gigs of ram just for graphics, lol. I might need 8 Gigs then.
  10. kurryman

    kurryman Newcomer, in training Topic Starter

    1. clean install of vista
    2.yeah 7.7
    3. i dont know

    and my mate he has only has 1gb of ram and hes got vista to.
  11. kpo6969

    kpo6969 TechSpot Maniac Posts: 875

    Post any info you have on your PSU: make, model, etc.
    How do you get 1.2GB? Post your mb
    1GB=1024mb
    1.2GB=1228.8mb

    Here's a link to ponder over:

    http://www.anandtech.com/gadgets/showdoc.aspx?i=3034
     
  12. kpo6969

    kpo6969 TechSpot Maniac Posts: 875

  13. kurryman

    kurryman Newcomer, in training Topic Starter

    oh yeah the 1.2gb is 1gb plus 256mb and now i got a extra 1gb but i had to take out the o256mb so now i have 2gb crucial blistex in total.

    the PSU i only can find out the model ky-500atx 400w p4.

    and the graphic card only needs 350watt it says in the ati and sapphire website, and i would like to point out a very werid thing, well basicly i swapped my GC (graphic card) with my mates GC with was a x1600 download grade from mine, his x1600 works alright on my pc but better on his, my x1650 works quite crap on mine but better on his???? and he's got 1gb ram and 230watt and im like WTF!!!

    this is really werid but then i ran cpu-z and i saw something that might cause the problem it was my BUS Speed (99.9mhz) and Rated FSB (399.5mhz) and his was double mine.

    BTW my mobo is a asrock P4i65G.
  14. kurryman

    kurryman Newcomer, in training Topic Starter

    well now im getting Intel Pentium 4 3.2GHz Extreme processor if that dont work im just gonna go out and get a new mobo.
  15. kurryman

    kurryman Newcomer, in training Topic Starter

    THANKS FOR ALL THE HELP, YOU LOT REALLY HELPED I MEAN COME ON I COULDNT OF THOUGHT OF DOING THAT, WHAT A CRAZY IDEA WOW I SHOULD TELL ALL MY FRIENDS ABOUT THIS BRILLENT WEBSITE!!!.


    you guys suck.


    btw it did work out in the end.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.