TechSpot

Major headache. Need so assistance.

By smore9648
Sep 9, 2006
Topic Status:
Not open for further replies.
  1. I have an issue that is getting very frustrating.

    Here is the back ground.

    System was loaded with a W2K Pro SP1 Image. I upgrade to SP4. I loaded a local user with user rights and another administrator. There is a DOS program we all use for work.

    I load all the software on the admin side and log off and go in as a regular user.

    The user receives the NTVDM has encountered a illegal instruction error. But when I go to the admin side I can access the program just fine.

    I am thinking of doing another reload but want to know if anyone else has any other recommendations
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 2,251


    Hi

    Try giving the user admin rights and see if that works.

    Regards
  3. smore9648

    smore9648 Newcomer, in training Topic Starter Posts: 757


    I already tried that and it works. But I do not want them to have admin rights.
  4. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 2,251

    Then I think you will have to just add the user to the rights of the system32\folder, this is where the file NTVDM.EXE exists, this usually inherits its rights from the root, unless you have changed that previously.

    Regards
  5. smore9648

    smore9648 Newcomer, in training Topic Starter Posts: 757

    The problem is, I think, is the image. The image that I am using was created by my company. They edit the GPOs and the registry. I have no clue what exact policies they edited but I wondering if that has anything to do it with.

    The system previously has xp pro on it with everything already loaded on it. But I experienced the same problem with that load. The admin had full range on access on the the programs and folders, like they should but when I created the user account, I tried to copy some directories to the user account and the files would generate the disk full or protected error. This was from within the the HDD not a CD or floppy. The read only attribute is there and I tried to remove the attribute but I keep receiving error when doing so. I am sure the GPO is wha t is causing the problem, there is not other explaination as far as I am concerned.

    At first I was think I misloaded it but now I am thinking the disk is old and has too many GP added in the image.
  6. smore9648

    smore9648 Newcomer, in training Topic Starter Posts: 757

    I am going to leave it at admin rights for now.

    Now I am having an issue installing the Video driver.

    Rage 128 Pro 32M AGP card. I went to ATIs site and downloaded the correct driver but its not loading. I receive a severe message and it says the driver loaded is not compatible with the installed video card. I doubled checked and its the right card and the right driver. WTF over
  7. mikescorpio81

    mikescorpio81 Newcomer, in training Posts: 574

    Do you know how to use the cmd line CACLS? Find the program files or whatever files you want your users to have and run a CACLS on those folders with certain switches to give them modify rights.

    Open a cmd prompt and type cacls /?

    Look into this option as some of my clients are in the same predicament and rather than giving the users admin rights I simply run a cacls batch file in their logon script :grinthumb
  8. smore9648

    smore9648 Newcomer, in training Topic Starter Posts: 757

    I think I found the problem. I reloaded the system with W2K sp1 and loaded the DOS program and created a new user, nothing else.

    The error was still there. I looked in to the user policy and noticed that the user assignement key as nothing in it other then an error message saying that it does not recognize the security inf file.

    So at least I have a starting point and hopefully that is the root of the problem.


    Thanks for tip. I have never used that before but I will give it a shot
  9. smore9648

    smore9648 Newcomer, in training Topic Starter Posts: 757

    I am an *****. I figured it out. I had to go to the roots properties and add everyone. Problem resolved. I feel dumb.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.