Massive Problems With 9800PRO

By MetalX
Jun 25, 2006
  1. I have a AIW 9800PRO and it had recently started to malfunction. Every time i launch a game, i get massive artifacts that cover the whole screen rendering the game unplayable. I have tried several different drivers including omega drivers and the problem just seems to be geting worse. The card is not overclocked, nor is it overheating (itis cool to the touch) because it has a good aftermarket cooler on it. Does anyone know that the problem might be?
  2. iss

    iss TechSpot Chancellor Posts: 1,994

    how long after adding the after market cooler did you start having problems?
  3. wolfram

    wolfram TechSpot Paladin Posts: 1,967   +9

    what`s cool to the touch? the cooler or the videocard itself?

    If the cooler it`s cool to the touch, heat is not being properly transferred to the heatsink. You`ll need to check it out.

    The problem REALLY sounds like overheating :hotouch:
  4. MetalX

    MetalX TechSpot Chancellor Topic Starter Posts: 1,388

    I know for a fact that it is not overheating. The card and the heatsink are both cool to the touch. One day, the card just started malfunctioning. It now refuses to run (no signal after windows has booted up) on ANY version of the ATI drivers or Omega drivers... I am running it on the drivers windows xp provides right now. The only thing out of the ordinary that happened recently is that I took it out of the case for about 10 minutes while i was cleaning dust off my fans and reorganising wires inside the case to improve airflow.
  5. korrupt

    korrupt TS Rookie Posts: 716

    there must be a problem with the motherboard, I noticed one of your threads also stated there is a problem with your optical drives...

    Check your motherboard and perhaps even processor.


Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...