TechSpot

Med Pc..high graphic card..still LAG

By zee3b
Jun 2, 2007
Topic Status:
Not open for further replies.
  1. Hey!

    Well im a F.E.A.R addict....i use to get a lot of lags... so i decided to upgrade my ram to 1.5 gig and bought X1950 hoping the lag would be gone.....it did empty my pocket...
    Unfortunately the lag is still there but the graphics look better.... i experience this stuttery play......tried many things... formatted whole hard drive... installed different windows..... but the glitchy play wont leave me alone....
    my processor is intel 2.8 HT and i have a high speed optic fobre 30 mbps connection.....
    Now what i have in my mind is ill buy a whole new pc... not forgetting that my pc is only 8 months old...and the fact that i already spent 300-400 in upgrading ram and graphic card...... so im not sure.. even if i upgrade my pc... would i still get lag....the stuutery play the glitchy play i experience...

    And yea guys i play on low settings....but still..... im starting to get sick of it.. and i dont want to risk.. another chance in buying a new pc... if i can fix my lag in this pc......

    Do help me guys... any help or advice would be appreciated.... and yea... one of my friend plays the game on 3.0 celeron 1 gig ram... with a low end graphic card and he doesnt get any lags..and im sure.. i can play it without lag too....:blackeye:
  2. MetalX

    MetalX TechSpot Chancellor Posts: 1,909

    Probably your ram isn't running in dual channel. That can severely limit memory bandwidth and gaming performance.

    I feel your pain... I'm a F.E.A.R. addict too ;) Name's MetalXâ„¢ if you ever see me.
  3. zee3b

    zee3b Newcomer, in training Topic Starter Posts: 45

    Hey!
    Thanks for the reply.........well i have one stick of 533 mhz 1 gig......and i aint saying my pc is slow... my pc runs like crazy..... i mean fast....i installed a whole copy of window in less then 15 mins......and most importantly when im playinf f.e.a.r its only uses like 2-3 or sometimes 4 % of my cpu...
    ...and still i get that lag...:( i checked my packet loss too... and pinged www.yahoo.com 3 times (100 pings each time) and it turned out to be 0%packet were loss... so im sure.. nothing wrong with my braodband.......or modem.....
    Anymore advice or help would be appreciated

    OH YEA i forgot to tell you all that.... my fps isnt low either i average about 150-220 fps.....means my graphic card is working fine..... i guess?
    Thankyou!
  4. mopar man

    mopar man TechSpot Ambassador Posts: 1,492

    What kind of lag? Is it like a skip?
  5. Condor

    Condor TechSpot Maniac Posts: 461

    How much ram does your X1950 has? if its 512 you shouldn't have lag or shutter problem.
  6. JimShady23

    JimShady23 TechSpot Maniac Posts: 651

    Hmm

    Do you have all the updates for the game installed ? Also, I experienced that problem only when I updated my graphics drivers. I think FEAR may be particular to certain ones. Try rolling back your catalyst drivers to an older driver or try the newest newest one.....
  7. jtickner1

    jtickner1 TechSpot Chancellor Posts: 663

    shouldnt get any lag with a 1950, i have an x1600xt with 1gb Ram and an Athlon 3200 and i run it maxed out fine. i agree with Jimshady patch the game and update your catalyst drivers.

    Dont know about going back to an older driver though
  8. zee3b

    zee3b Newcomer, in training Topic Starter Posts: 45

    Hey!
    Thanks for the replies guys....
    Well Jim i totally agree with you i started laging more after updating my drivers.... so i formatted my pc and installed the ones which came with it and it worked much better and also i think my lag is because of my integrated sound. I ordered steel series which come with the usb soundcard hope that fixes my lag if not.... then im afraid ill have to buy a new mother board and a processor ( a combo i guess) and transfer my other hardware to it.
    hey by the way do u recommend any motherboard and amd processor to go along with my ati X1950 higher then 4400 dual core would be preferred.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.