Microsoft Sidewinder precision 2 joystick

By nbquidditch
Mar 25, 2007
  1. Hi guys.. My 1st post & I need your help! I'm a keen Flight Sim 2004 addic and have been using a Microsoft Sidewinder Precesion 2 Joystick for around a month now with no problem. The joystick originally installed automatically in XP.
    I fired my computer today and suddenly the joystick does'nt work. In fact there's no sign of it. I went to Game controllers in Control panel located my joystick and clicked add to try & re-install. I now get a message saying ' Your Gameport or Gameport Drivers are not properly configured. Please consult the device manager'. I go to the Device Manager & my joysticks not there either. What's happened?? It was working perfectly when I turned off my computer earlier.

  2. sghiznaneck

    sghiznaneck TS Maniac Posts: 403

    Try to see if you can find the drivers in the Contpol Panel>Remove programs sectoin. If it's there, uninstall it and conduct a fresh install from the Sidewinder disk that came with it. This could have occured due to a driver becoming corrupt.
  3. nbquidditch

    nbquidditch TS Rookie Topic Starter

    Thanks sghiznaneck.. I looked but there's nothing there in Add/Remove programs. I tried reloading with my install disk anyway but for some reason the installation just hangs when I click on install. Originally I didn't need the install disk. I just plugged it in and it worked. This is very frustrating.
  4. sghiznaneck

    sghiznaneck TS Maniac Posts: 403

    There's a good possibility that the drivers have become corrupted. You may have to to an XP Repair, NOT a complet install. The disk will run and take a snapshot of your configuration and fix only what it needs to. All your files will still be intact, but the system will overwrite itself to correct all errors.
  5. nbquidditch

    nbquidditch TS Rookie Topic Starter

    Thanks Again sghiznaneck but not sure exactly what you mean! Do you mean a repair using the XP disk? If so this is not possible as XP was pre-loaded on my pc or is there another way?? Sorry if I sound a bit thick.
  6. sghiznaneck

    sghiznaneck TS Maniac Posts: 403

    That's exactly what I meant, but with pre-manufactured pc's you aren't provided with anything other than a recovery disk. Have you tried going way back to a restore point??
  7. nbquidditch

    nbquidditch TS Rookie Topic Starter


    Thanks sghiznaneck I tried going back a month but it made no difference. However, I've solved the issue. On reboot I pressed the F12 key and came up with a diagnostic list. Within was a section where you could check your game controllers & ports etc so I ran the diag. All my ports etc passed ok so I wasn't confident but when I came out of diag and back into Windows my pc (Dell Inspiron 9400) immediately recognised my Joystick and bingo everthing was working again! Looks like the diag reset everything!
    I want to thank you anyway for taking the time to post & give me some ideas. Cheers mate.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...