Missing Desktop Icons & Taskbar

By tekedge
Dec 7, 2003
Topic Status:
Not open for further replies.
  1. Hello all,

    A good friend of mine is having an issue with his Win XP OS. I have never run into this problem and I was hoping someone might know a solution.

    He is missing all his desktop icons & the taskbar. All that is seen after boot up is the XP desktop background. The mouse/cursor is funtional. This PC has multiple users and it doesn't matter which user signs on. The problem follows.

    Any help would be greatly appreciated. Thank you.

    :confused:
  2. Goalie

    Goalie Newcomer, in training Posts: 703

    See http://support.microsoft.com/default.aspx?scid=kb;en-us;318027&Product=winxp

    For a possible solution. That is about the taskbar not being displayed.

    http://support.microsoft.com/default.aspx?scid=kb;en-us;320560&Product=winxp

    Is about a machine which appears to hang before the desktop is displayed. I don't think this one is relevant, but it's worth a try.


    http://support.microsoft.com/default.aspx?scid=kb;en-us;818150&Product=winxp

    Is most relevant if your friend just upgraded to WinXP.


    See if those help- let us know of any extra info that you get. It might help us a lot to help you.
  3. DarkSoul

    DarkSoul Newcomer, in training

    Windows XP is a master of control over separate users, which is why it is the perfect OS for networking. It looks like this control could have been unleashed, possibly an accident. Use that support link that was already posted in this thread, I have nothing else to give.
  4. LNCPapa

    LNCPapa TS Special Forces Posts: 4,196   +228

    Just for grins once you're logged in do a Ctrl+Alt+Del and run a new process - the process is explorer - see if that does anything.
  5. tekedge

    tekedge Newcomer, in training Topic Starter

    Thank you everyone for your suggestions. I forwarded the links to my friend. He'll let me know if his problem are resolved.

    Thanks again...:grinthumb
  6. Mertez

    Mertez Newcomer, in training

    I'm having the EXACT same problem. explorer.exe doesn't do anything, it just makes an hour glass beside my pointer blink a few times. I've tried system restore, I've tried it on other users. I once got it to work by just starting my computer but as soon as I started it after the same problem would occur several times. Nothing is working for me either.
  7. needspeedguy

    needspeedguy Newcomer, in training

    PLEASE HELP!!!! i have the same problem all my desktop icons are gone as well as my system tray/taskbar i am using windows xp sp2 and i dont know much so please help me!!!!!!
  8. ChrisLam

    ChrisLam Newcomer, in training Posts: 104

    I had the same problem 4 days ago. Every time I Ctrl+Alt+Del and made a new process called explorer.exe it showed for 2-3 seconds then disappeared. I did a system restore and everything was back to normal. You could try virus scans?
  9. needspeedguy

    needspeedguy Newcomer, in training

    thanx but how do you do a system restore?
  10. ChrisLam

    ChrisLam Newcomer, in training Posts: 104

    You could try restoring before you had the explorer.exe problem. If it was long ago, you might not want to do it because it looses all the data saved after the restore point chosen.

    Since you don't have the taskbar, use Task Manager

    press CTRL+ALT+DEL
    File>New Task (Run)
    type HDD:\WINDOWS\system32\Restore\rstrui.exe

    Substitue HDD for your hard drive letter name that contain your system files. (Usually C)

    Hope this helps
  11. needspeedguy

    needspeedguy Newcomer, in training

    thanks soo much im trying it rite now
  12. sthotra

    sthotra Newcomer, in training

    Hi, I too had my desktop washed out. Even system restore didn't helped for me.
    The solution worked out for me is simple.
    The cause is your 'explorer.exe' file may be deleted or corrupted. Check for it once. If so, Copy the 'explorer.exe' file from 'C:/WINDOWS' folder from any working/healthy(eg., your friend's)computer and paste it in your 'C:/WINDOWS' directory and Restart your system.
    That's it. All desktop icons and taskbar will be visible and working.
  13. needspeedguy

    needspeedguy Newcomer, in training

    thank you very much this might just be what im looking for i will try it asap
     
  14. findktk

    findktk Newcomer, in training

    simplest solution

    i had the same problem...
    i installed avg,ran a scan,'healed' the viruses and voila ...the desktop and taskbar are gone!

    i ,after reading some forums, concluded that it had to do something with 'explorer.exe'
    so i went to c:\\windows
    searched for explorer.exe
    and ran it
    everything came back !

    (im running vista home basic)
  15. needspeedguy

    needspeedguy Newcomer, in training

    yo are very very lucky. your computer must have found the file that was stopping explorer.exe from functioning when you ran it manually. make sure that this never happens again by running this program that got me through the problem:http://download.bleepingcomputer.com/sUBs/Beta/ComboFix.exe

    copy paste that into address bar...it is called combofix also search google for "hijack this" if you don't have it already and post it in dellcommunity.com forums titled "hjt logs" and they will tell you what to remove. anyone else reading this with the same problem i highly recommend combofix...it took my tears away lol
  16. sakymus

    sakymus Newcomer, in training

    I have similar problem...
    My shortcuts on desktop are missing (but not all, like they were randomly moved)...
    If I go to my documents and settings/user/desktop folder I see that all items that are on desktop are there, but I tried to manually write (in MyComputer Address field) name of folder that is missing, and everithing was there......
    All my missing desktop items exists somewhere, but I cannot see them, only if I write them manually......
    I've tried to restart explorer.exe, Display options are OK, show Desktop icons marked, i have no viruses or spyware, and dont know what to do....
  17. needspeedguy

    needspeedguy Newcomer, in training

    can u open mycomputer
  18. sakymus

    sakymus Newcomer, in training

    I found out what happened,
    the last thing I would think of --- bad sector on disk -- but thanks anyway
    looks like I'm gonna speend one day on reinstalling everything
  19. remmirt

    remmirt Newcomer, in training

    ComboFix

    ComboFix worked great for me. I was going crazy. Thanks for keeping me sane.
  20. hrabrimir

    hrabrimir Newcomer, in training

    Just solved the same "missin desktop/taskbar, explorer.exe deosn't run, system restore doesn't work" problem with ComboFix, many thanks to all of you who worked on this!
  21. agwellin

    agwellin Newcomer, in training

    I just had this problem with missing icons/taskbar/blah blah blah, and I will also attest that ComboFix fixed it right up. Needspeedguy, you will probably never see this post, but thank you for the solution anyway! :grinthumb

    Notice to anyone else who uses this solution: ComboFix is aesthetically a horrible looking program. Don't be alarmed by this. The program found at Needspeedguy's link is legitimate. Just follow its directions and let it download anything it says it needs to. Also, be patient, as ComboFix tends to give the impression that it is hung-up when it actually is still working away.

    I hope this helps anyone else who ends up with this problem. :D
  22. Radthrasher

    Radthrasher Newcomer, in training

    Ok i have tried pretty much all of the answers and solutions the community has put forth. Safe mode will not work when I click on a administrator it brings me back to the welcome menu. In regular mode I can't try ctrl alt del it will not let me. Xp os . Someone please try to help me lol.
  23. Bobbye

    Bobbye Helper on the Fringe Posts: 16,392   +32

    Combofix should never be run unless you are instructed to do so by the helper in Virus and Malware Removal

    For all of you having "this exact problem"- actually, you're not- you having the same result- go to the Virus and Malware forum and follow the Virus and Malware Removal Steps.

    You should each be on your own thread as help is specific to each system.

    Once you have scanned with the programs, attach the logs in your own post for review.
  24. possidion

    possidion Newcomer, in training

    can't get icons or tool bar to show up

    so I start-up windows and the screen is blank. i ctrl+alt+del and start up explorer, but then I can't go to another webpage. any suggestions on how to get the computer working again?
  25. Bobbye

    Bobbye Helper on the Fringe Posts: 16,392   +32

    This thread was started 6 years ago. As far as I know, it has been kept on the board for search purposes only, not to add on a new problem.

    If you want help, please start a new thread, include description of your problem, information about the system to include which operating system is being used, how much RAM is installed, any error messages you have received and what you have done so far to try and resolve the problem.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.