TechSpot

Missing usb1.1 drivers

By Grizwold
Sep 18, 2004
  1. Anyone know where I can get drivers for a NET-A-USB114 usb hub?

    Grizzy
     
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Linux drivers? DOS drivers? Drivers for QNX? Windows 98 perhaps?
     
  3. Grizwold

    Grizwold TS Rookie Topic Starter Posts: 18

    I don't think it makes any difference as long as they will run this usb hub. For one thing there is no-one that I personally know that runs any cutting edge programs. Linux is practically unheard of down east here. The hub should have come with a driver disk but it didn't. It's only worth about 8 bucks but it's become personal between myself & it! Know what I mean. I hate to be outsmarted by an inanimate piece of plastic! The Griz
     
  4. Hodsocks

    Hodsocks TS Guru Posts: 370

    Hmmmm....... none of the USB hubs I have installed have needed a driver, just plug them into the usb on the pc and away they go.
     
  5. Grizwold

    Grizwold TS Rookie Topic Starter Posts: 18

    You're probably right Hodsocks. I was just grasping at straws. The darn thing is probably faulty. I've tried everything! About the only other thing I can think of is that there may be a problem with the usb controller. What do you think everyone?
     
  6. Grizwold

    Grizwold TS Rookie Topic Starter Posts: 18

    Also, this stupid thing has no power supply of it's own. It draws power from the cpu. I have seen some advertised that came with their own power supplies.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...