TechSpot

MOHAA not compatible with new Intel Pentium D 820

By bikette13
Apr 4, 2006
  1. Hello, I just buy a new PC with an Intel Pentium D 820 at 2.8Ghz. I've try to install my Medal Of Honor Allied Assault game but when I start the game, it gives me an error and don't start. It seems that the game dose not recognise the processor as a 2.8GHz but as a -1575mhz...so the game won't start !! Have you ever experience something like that ??

    Thanks for your help.
     
  2. bushwhacker

    bushwhacker TechSpot Chancellor Posts: 783

    One... put your system specs in your member list.
    two... you can update your chipset drivers at www.intel.com
    three... update your video card drivers.
    four... check and download MOHAA updates from the EA Games.
     
  3. bikette13

    bikette13 TS Rookie Topic Starter

    I have update system info in my profile. I will update my driver tonight with the latest from DELL. I have already update MOHAA from EA with Patch 1.11. No other patch is existing. Keep you inform after updates done.

    Thanks
     
  4. bushwhacker

    bushwhacker TechSpot Chancellor Posts: 783

    Put the dell Service Tag number in your profile, damn it! :) we will be waiting
     
  5. SOcRatEs

    SOcRatEs TechSpot Paladin Posts: 966

    Hello! Welcome to TechSpot!

    What error are you getting, a game error or a windows error?
     
  6. bikette13

    bikette13 TS Rookie Topic Starter

    It gives me a windows error when I try to start the game. The game is the original version and have always work on my previous computer. When I look in minimum requirement of EA into the Easy Info tool provide with the game, my processor is shown like it's a -1501Mhz and it's a double 2.8Ghz and the tool tell me that my processor don't meet the requirement. I've try to send e-mail to EA but I don't think I will have support for this...
     
  7. bikette13

    bikette13 TS Rookie Topic Starter

    Dose anyone as the same processor than me ? Intel Pentium D 2.8GHz (820)
     
  8. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Have you tried forcing the application to use only one CPU core (with Task Manager or StartAffinity) ?
     
  9. bikette13

    bikette13 TS Rookie Topic Starter

    Thanks for your help guys it was probably related to screen mode. I've started the game in safe mode and it was working, I've done setting of display mode and not it start in normal mode without problem. No processor issue...but still in the status screen it dose not recognize the processor speed but not problem anymore.

    Thanks again
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...