Monitor says "No video Input, monitor going to sleep"

By Someoneeeee
Mar 27, 2016
Post New Reply
  1. Okay so I was surfing the net with my pc. I was bored. So I decided to clean my pc's insides with vacuum cleaner. I did it. Then I tried to turn my pc on, my monitor showed me "No video Input, monitor going to sleep"
    I tried my monitor with different PC, it worked. So it's not the monitor that is a problem. I checked my motherboard light, it's nice bright green. No beeps.
    What is the issue? May I have moved some cables with the vacuum cleaner? or did I swallow something? Please help :)
    Last edited by a moderator: Mar 27, 2016
  2. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +241

    You may have caused a static charge to the video chip. This may have burn the chip out
  3. bazz2004

    bazz2004 TS Evangelist Posts: 1,213   +200

    Buy an air can for future use because this could be an expensive mistake.
  4. Someoneeeee

    Someoneeeee TS Rookie Topic Starter

    Thank you very much for your interest in helping me!
    Unfortunately, this is solved ^^. All I did was unplug my pc's insides and plug em again.
    Again, thanks! <3
  5. bazz2004

    bazz2004 TS Evangelist Posts: 1,213   +200

    I think you mean "Fortunately, this is solved." Cobalt006 is probably correct and the vacuum cleaner caused a static issue. You have had a close escape.
    Cobalt006 and Tmagic650 like this.
  6. Someoneeeee

    Someoneeeee TS Rookie Topic Starter

    Yes sorry, haha. :)

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...