TechSpot

Motherboard Help

By Kf21291
May 21, 2005
  1. I need some help installing a motherboard. The problem is my computer won't turn on. I think its the power switch from my case power botton to the mobo connectors. So I need some help installing those. Along with installing the front USB. E-mail if u want to see the problem ( i send pic) thank you.
    Email- kf21291@gmail.com
    Mobo- PC Chips Model- M960G
     
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Disconnect all the wires from the front panel and replace them carefully. If you look in your mobo manual it will show you which wires go where.

    Regards Howard :grinthumb
     
  3. Kf21291

    Kf21291 TS Rookie Topic Starter

    I removed the motherboard and replaced it with the original one and I got the computer to turn on, but nothing is displayed on the screen. I don't know what is going on it, I need some help. I'm not sure if i destroyed the motherboard :dead: But theres something wrong i connected everything exept the USB headers (Front Ports)
     
  4. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    Did you connect the CPU power? Did you connect the MB power?

    I remember once I failed to plug in the cpu power line.
     
  5. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    Tedster ,please add more information
    MB manufacturer
    OS you use
    memory size
    graphic card if any

    thank You
     
  6. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    I'm not the one with the issue.
     
  7. Kf21291

    Kf21291 TS Rookie Topic Starter

    ahhh nevermind what i posted before. I'm getting a NEW motherboard again. Because i believe they sent me a defect. So, please someone go over the steps on how to install a motherboard. Including precautions and ways of not getting static in the motherboard cause that would destoy it. But anyway please help me how to install everything on to the motherboard and make it back to normal. Cause i got the computer to turn on with the original motherboard i installed on to it, but nothing displayed on the monitor nothing, HDD Led not blinking, Power led nope. Note: i checked monitor pluged in, power pluged in. What else can be the problem?? I know it was on cause i can see the fans move and my power supply fan move and my neon turned on. Please help
     
  8. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Take a look HERE for a step by step guide on how to build a pc.

    Buy yourself an antistatic wrist strap like this. They are only cheap, and can save you lots of time touble and money.

    Regards Howard :grinthumb
     
  9. Kf21291

    Kf21291 TS Rookie Topic Starter

    O ok thank you for those helpful links i will take a look at them thanks. :)
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...