Mouse Locking Up?!

By etherga
Jun 5, 2005
  1. I've had this new computer built for about 3 weeks now. And It seems that ever since about 2 weeks ago the mouse peridically freezes up for 1-2 seconds at a time. At first i only noticed it while gaming since i would be moving the mouse almost constantly. However, recently i've noticed that it does it while on the desktop. Other functions continue while its locked up, i.e. game still runs smooth etc. its just that the mouse stops moving. Any ideas on this one? I'm pretty stumped. Its a logitech optical mouse.

    Note: The mousei s about 2 years old. I dont know if these things wear out or anything, or if they do what their behavior is. anyone had one wear out before?
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Try another mouse. If this doesn`t solve the problem, then post back.

    Regards Howard
  3. etherga

    etherga TS Rookie Topic Starter Posts: 51

    i've got a new mouse on order howard so i wont really know whether it is doing it with diff mouses till it comes in. However, i'm curious that if it is not the mouse, what problem could it be. I mean maybe something with the motherboard? I've tried every USB port on the thing and i still have the same problems. A few times the other day the mouse completely turned itself off. So i'm fairly sure its not an issue of the CPU getting bogged down, because when it happend i was able to navigate through the desktop with the keyboard easily. However when i unplugged its USB cable and plugged it back in, the mouse came back on. it still "locks up" every now and then though. Any ideas?
  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Does your mouse have an adaptor, so that you can plug it in to the ps/2 port?

    If it does give it a try.

    Regards Howard :grinthumb
  5. tdeg

    tdeg TS Rookie Posts: 119

    Are you in the middle of using it when it locks up? Optical mice will turn off their led when they haven't been used in a while and it may take a second or two after you first move it for it to register movement again.
  6. patio

    patio TS Maniac Posts: 482

    As Howard said let us know if the new one runs OK...
    Two other common problems that cause this
    Vid card---you can try re-installing the latest video drivers...

    Memory. DLoad and run MemTest and see what results it shows.

    Hopefully though it's just the mouse.

    patio. ;)
  7. etherga

    etherga TS Rookie Topic Starter Posts: 51

    Dont have an adapter to switch it from usb to the other one.

    Up until last night, the problem only was occuring when i was using the mouse. But last night the mouse completely turned off (LED went out and wouldnt work) at some point and was still off when i woke up in the morning and tried to use it. It starts working again when i unplug/plug it back into the usb port.

    Gonna dl memtest right now and see what it puts out
  8. etherga

    etherga TS Rookie Topic Starter Posts: 51

    Just tried to run memtest, i burned the ISO to a bootable CD and restarted, and on reboot is said "Cannot start DOS! Press a key to retry".
    So i tried it a few times and it wont work. so back to square one! :p
  9. Ender1

    Ender1 TS Rookie


    Are you running ventrilo? It seems thats what is causing the problem for me...
  10. insoman

    insoman TS Booster Posts: 102

    have you tried changing the battery if battery powered. I had this and found the problem to be a metal desk near my phone master socket. interference.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...