TechSpot

Mouse not recognized...

By ryejay98
Jul 12, 2002
  1. So I started up X and the mouse wasn't working. When I killed the X server, I received the following message:

    (EE) xf86OpenSerial: Cannot open device /dev/mouse
    No such device or address
     
  2. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Which mouse is it? Serial, PS/2 or USB?
    If it's serial in COM1, create a link (as root)
    cd dev
    ln -s ttyS0 mouse

    For COM2, replace ttyS0 with ttyS1. For PS/2, replace ttyS0 with psaux. I'm not sure about USB.
    Note: xf86config can put the right values into your X config files, too. I accidentally said earlier that the command is xf86setup, that's obsolete.
     
  3. ryejay98

    ryejay98 TS Rookie Topic Starter Posts: 41

    Did that ... got the same error message, including:

    (EE) Mouse0: cannot open input device

    (EE) PreInit failed for input device "Mouse0"
     
  4. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    If your BIOS has a setting "USB keyboard/mouse controlled by" OS/BIOS, change it.
     
  5. ryejay98

    ryejay98 TS Rookie Topic Starter Posts: 41

    The mouse works fine when using XFree 4.1 ... it wasnt until 4.2 that came out that the mouse stopped working ...

    I have no option like you mentioned in my bios
     
  6. ryejay98

    ryejay98 TS Rookie Topic Starter Posts: 41

    On another interesting note, cat /proc/interupts does NOT show my mouse ... so ... UGH!
     
  7. ryejay98

    ryejay98 TS Rookie Topic Starter Posts: 41

    The only thing I found that works was to buy a usb->ps/2 converter for my keyboard. When I plugged the keyboard into a standard ps/2 port ... suddenly Linux recognized my ps/2 mouse.

    There's gotta be another way ... but ... hey, it works for now!
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...