My DVI Blank Screen from boot solution

By Varr
Sep 17, 2006
Topic Status:
Not open for further replies.
  1. I have an ASUS A7N8X Deluxe motherboard, 2600+ XP AMD processor, ATI Radeon 9500 Duel Pro video card, and Samsung SyncMaster 215TW flat panel display. After dealing with support for ASUS, ATI, and Samsung all blaming each other for the problem I solved it myself.

    Problem: After the display had been working fine I was getting a blank screen at boot up. I tried everything all the support sites said, “Disable USB support on motherboard, powered on the display before computer, updated all drivers.” I was only able to get the display to be detected by using the DVI-I to VGA adapter. Only once in a blue moon would the display be detected using the DVI-D cable.

    After resetting my bios 30 times, reseating the video card 10 times, and testing all the ports on my display and video card, hours reading the support forums, I figured it out. When my display was detected the EDID information for my display frequency was 75Hz though Samsung reports it to be 60Hz when run at 1680x1050. My motherboard’s default bios setting is auto and does not have 60Hz. Samsung support told me to low the refresh rate in Windows when the display was detected WRONG. I would not get the port to detect monitor. If I set the bios to 50Hz for the AGP bus the computer would not boot. Then I set it to 66Hz the next setting no boot. Then I tried 75Hz the computer booted but the display was not detected. Then there was some information on a support for DVI problems with DVI-D cable and voltage levels. With my bios I was able to step the voltage for the AGP slot 1.5, 1.6, and 1.7. Default was 1.5, at 1.6 blank screen, 1.7 bingo display worked and was detected from boot up.

    Solution: Use analog VGA connection to get into bios, and have DVI connected to display at the same time. Set the AGP frequency to 75Hz (or Detected EDID Hz) and voltage to 1.7 (or default then step up to next option). Once in windows switch the source to digital and make it the default display. Then disable the VGA if you are not going to use it. Reboot if needed and display should be sent digital signal from boot up to Windows. Also I have the ATI control panel reduce to DVI frequency for high-resolution displays.

    Hope this helps others having this blank screen from boot up issue.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.