TechSpot

My first post! FAILURE_BUCKET_ID: IP_MISALIGNED_atapi.sys - Rebooting

By happyjohnny
Sep 18, 2006
  1. Hi Guys,

    This is my very first post here! - I look forward to many more posts and adding to the support community when and where I can.

    I'm having a problem with a computer I'm working on and just wondering if anyone has any ideas on what the exact problem is and how to fix it...

    Ran hijackthis and cleared out everything that wasn't essential.

    Ran pc through Memtest and passing multiple tests without error

    Gave the computer a standard spyware and virus check with nothing serious.

    ok... the problem

    The computer will intermittantly reboot itself / BSOD
    I've attached a handfull of minidumps centred around the problem - looks like it could be pointing to atapi.sys

    Bugcheck Analysis:
    DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)
    An attempt was made to access a pageable (or completely invalid) address at an
    interrupt request level (IRQL) that is too high. This is usually
    caused by drivers using improper addresses.
    If kernel debugger is available get stack backtrace.

    FAULTING_MODULE: 804d7000 nt

    DEBUG_FLR_IMAGE_TIMESTAMP: 0

    READ_ADDRESS: unable to get nt!MmSpecialPoolStart
    unable to get nt!MmSpecialPoolEnd
    unable to get nt!MmPoolCodeStart
    unable to get nt!MmPoolCodeEnd
    ffffffd5

    CURRENT_IRQL: 5

    FAULTING_IP:
    atapi+5600
    baf48600 d874118b fdiv dword ptr [ecx+edx-75h]

    CUSTOMER_CRASH_COUNT: 1

    DEFAULT_BUCKET_ID: DRIVER_FAULT

    BUGCHECK_STR: 0xD1

    MISALIGNED_IP:
    atapi+5600
    baf48600 d874118b fdiv dword ptr [ecx+edx-75h]

    LAST_CONTROL_TRANSFER: from f87622d2 to baf48600

    STACK_TEXT:
    WARNING: Stack unwind information not available. Following frames may be wrong.
    80550140 f87622d2 badb0d00 00000048 ffdffc70 atapi+0x5600
    805501d0 804dbb37 00000000 0000000e 00000000 p3+0x22d2
    805501d4 00000000 0000000e 00000000 00000000 nt+0x4b37

    STACK_COMMAND: kb

    FOLLOWUP_IP:
    atapi+5600
    baf48600 d874118b fdiv dword ptr [ecx+edx-75h]

    SYMBOL_STACK_INDEX: 0

    FOLLOWUP_NAME: MachineOwner

    IMAGE_NAME: hardware

    SYMBOL_NAME: atapi+5600

    MODULE_NAME: hardware

    FAILURE_BUCKET_ID: IP_MISALIGNED_atapi.sys

    BUCKET_ID: IP_MISALIGNED_atapi.sys

    Followup: MachineOwner


    Can you help? Any ideas of what the fault could be and any solutions? - I have my suspicions but would like some extra opinions please :)

    Many thanks

    Johnny
     
  2. smore9648

    smore9648 TS Rookie Posts: 697

    Its your CD/DVD Rom.
     
  3. happyjohnny

    happyjohnny TS Rookie Topic Starter

    Thanks for your reply smore9648; however I have since replaced the CD Rom and the problem is still happening.

    Does anyone else have any ideas?

    Could this be a driver fault?
     
  4. happyjohnny

    happyjohnny TS Rookie Topic Starter

    Does anyone have any other ideas? - please
     
  5. smore9648

    smore9648 TS Rookie Posts: 697

    Have you updated your firmware?
     
  6. happyjohnny

    happyjohnny TS Rookie Topic Starter

    No - haven't updated the firmware... which component are you referring to? I've already replaced the CD Rom.
     
  7. peterdiva

    peterdiva TechSpot Ambassador Posts: 1,088

    The ones that aren't caused by atapi.sys are caused by portcls.sys. Try updating the onboard sound drivers.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...