TechSpot

My memory is running slower than it should.

By matchboxmatt
Aug 4, 2007
  1. Is the CPU's FSB to blame, or am I supposed to tweak some settings in the BIOS in order to get the speeds the RAM was designed for?


    First off, my specs:

    Gigabyte P35-DS3R Mobo
    Intel P4 531 - 3.0Ghz 200MhzBus 800MhzFSB
    Corsair 2x512MB PC 6400 RAM - DDR2 800 4-4-4-12


    I recently tried out the CPU-Z program only to find that (under the SPD tab) that the frequency was at 400Mhz, with the right timings listed under. Then (under the memory tab), I found this:

    Frequency - 400~Mhz
    FSB: DRAM - 1:2
    CAS# Latency - 5 clocks
    RAS# to CAS# Delay - 5 clocks
    RAS# Precharge - 5 clocks
    Cycle Time (Tras) - 18 clocks

    Is this supposed to happen? Are the timings supposed to be this loose? Isn't it supposed to run at a frequency of 800Mhz?

    I have a moderate understanding of PCs, and I built this one myself; but I have no clue what to do when it comes to over-clocking and the details. Can anyone explain this?
     
  2. CMH

    CMH TechSpot Chancellor Posts: 2,573   +9

    DDR RAM is Double Data Rate, which means the Frequency listed in CPUz is correct (400x2 = 800mhz).

    However, your timings aren't right. You might need to go into BIOS and change them yourself to 4-4-4-12. I'm not too sure, but this might be caused by JEDEC's specs for DDR2 running at 800mhz.

    While you're messing around with BIOS, you might want to try tighter timings :D
     
  3. matchboxmatt

    matchboxmatt TS Rookie Topic Starter Posts: 20

    Thanks. That's somewhat of a relief. :p

    How do I actually change the timings though? There's nothing that says anything about timings in the BIOS. :<
     
  4. Jesse_hz

    Jesse_hz TS Maniac Posts: 638

    You need to press Ctrl+F1 to get to make it display the memory latency settings.
     
  5. CMH

    CMH TechSpot Chancellor Posts: 2,573   +9

    at the main BIOS menu, you might need to press CTRL-F1 to access timings. Should come up with CPU overclocking page as a whole lot of mess, but you should recognize the 5-5-5-18 somewhere in there, and change it to 4-4-4-12.
     
  6. matchboxmatt

    matchboxmatt TS Rookie Topic Starter Posts: 20

    Thanks for the help. I was able to change the memory timings, and I'm already beginning to notice a boost in stability under Vista.

    TechSpot comes through for me again. <3
     
  7. matchboxmatt

    matchboxmatt TS Rookie Topic Starter Posts: 20

    I've hit a road-block. My PC crashed twice under the 4-4-4-12 timings. I have a couple mini-dumps here if anyone can make sense of what happened. In the meanwhile, I reset the configuration.

    I only made changes to the 4 timing options. Was I supposed to change the voltages or other options as well?
     
  8. Jesse_hz

    Jesse_hz TS Maniac Posts: 638

    It would seem that the RAM can't handle the tight timings, but that can't be right since you said they were rated at 4-4-4-12.

    There should be more than 4 timing options in the BIOS (there's a hell of a lot more in my BIOS), my guess is that you changed the wrong ones, but I could be wrong.

    Does CPU-Z report the memory as running at 4-4-4-12?
     
  9. matchboxmatt

    matchboxmatt TS Rookie Topic Starter Posts: 20

    It did before I place the configuration back on auto. It's back to 5-5-5-18 now.

    All the other properties (7 other options out of the 4 timing options) I saw were on [Auto] besides the four timings. However, when I modified the timings, the option "ACT DELAY" changed from 42 to 0. There was no option to place it on Auto. Would changing it back help? Or would it be a better idea to just use different timings?
     
  10. CMH

    CMH TechSpot Chancellor Posts: 2,573   +9

    Put ACt Delay down to 40 and see if that helps. I know my RAM won't do anything less than 27 without showing very minor instability (basically means won't pass Orthos, but I don't see any problems).

    Basically, most (if not all) the numbers there, if you lowered them, you're asking more of the mem. If they are lower than default, and you've got instability, increase them.
     
  11. matchboxmatt

    matchboxmatt TS Rookie Topic Starter Posts: 20

    I placed it on 5-5-5-12 timings, placed the ACT Delay at 42, and left everything else on auto (when I pressed it to the default figures, it wouldn't boot). It runs perfectly fine on these settings, but according to CPU-Z, the RAM should have a rating of 4-4-4-12 (TRC - 22, Command Rate - 2T). The TRC was default at 2, but when configuring it, I left it on auto.

    Would tightening the timings back to 4, leaving the ACT delay at 42, and then changing the TRC to 22 work? I have no idea what "Command Rate" means, but I'd really like to shorten the delay timings.

    I also heard that the CPU FSB needs to match the memory, and that a processor with 800FSB should have 667 RAM. If I lower the frequency and tighten the timings, would it work out at 4 or 3? Would that boost my performance?
     
     
  12. captaincranky

    captaincranky TechSpot Addict Posts: 10,821   +922

    Time..Time....Time....

    As I understand it, The Intel chipsets don't like tight RAM timing. Particularly the 965 chipsets and specifically with DDR-800. They likely won't boot if the RAM latency is below 5. I'm thinking the P35 is an Intel chipset, if it isn't, please let me know and I'll be quiet.
     
  13. matchboxmatt

    matchboxmatt TS Rookie Topic Starter Posts: 20

    According to my RAM, it needs a voltage of 2.1v, and the BIOS has it set to "normal". I'm not sure if it automatically gives it 2.1 or not, but would increasing the voltage along with the timings work? :/

    The P35 is an intel chipset, but several people have gotten lower timings with it, apparently.
     
  14. Jesse_hz

    Jesse_hz TS Maniac Posts: 638

    That could be the reason. Try raising the voltage 0.1 or 0.2v and see if that helps. Don't give them too much.
     
  15. matchboxmatt

    matchboxmatt TS Rookie Topic Starter Posts: 20

    I just realized something about my RAM:

    SPD programmed at:

    JEDEC standard 5-5-5-15 values at 800MHz
    EPP standard 4-4-4-12, 2.1V values at 800MHz

    According to SPDTool, the JEDEC standard is 1.8v, which is why I'm getting those times instead. My mobo was using JEDEC instead of EPP. So, if I bump down the timings to 4-4-4-12, add +.3v, and keep the TRFC at 42, it should do the trick, right? Or do I need to touch the other settings too?

    I could enable EPP, but I have no clue how to do that.
     
  16. CMH

    CMH TechSpot Chancellor Posts: 2,573   +9

    Good on ya for catching on that voltage rating.

    Yeah, you'll need to increase your volts. .2 should be enough, and its what I've got mine on anyway.

    As far as Intel chipset not liking low latencies, I've got my 965P chipset running my 800mhz RAM at 4-4-3-5, 852mhz. 1:1 with CPU of course.

    Timings will boost performance, but its effects really is very minuscule. Lower ram timings are good for overclocking, it means you can increase the timings and get the RAM to go faster.

    Personally, if you really want to get CPU running 1:1, I'd rather increase the CPU FSB to match the RAM rather than lower RAM speed to match CPU. You won't see an improvement by lowering RAM speed imo, even if you did tighten the timings.

    Command rate, if you can get to 1T, that'd make it VERY good RAM. Feel free to try it, but make sure you know how to reset your BIOS, since if it doesn't work, your computer will not boot at all. A BIOS reset will fix it with no repercussions (not that I know of).
     
  17. matchboxmatt

    matchboxmatt TS Rookie Topic Starter Posts: 20

    Thanks. I was finally able to get my PC stable at 4-4-4-12 on 2.1v, with no BSODs occuring in PC Mark 05 and 3D Mark 06.

    About my 1:2 ratio. Would it really improve performance overclocking the P4 to match it 1:1, or would it just be a better idea to get a 1333FSB processor later on? I'm not familiar as to what clock the FSB should be in order to match the DDR 800.
     
  18. CMH

    CMH TechSpot Chancellor Posts: 2,573   +9

    FSB clock should bet at 400. Also, you will need to set RAM:CPU ratio to 1:1.
     
  19. matchboxmatt

    matchboxmatt TS Rookie Topic Starter Posts: 20

    Are you sure? It's 1:2 FSB to RAM, but they're both at 800. How do I manually change the ratio?
     
  20. CMH

    CMH TechSpot Chancellor Posts: 2,573   +9

    1:2 should be the same thing. It gets kinda confusing, since RAM speed is 2x FSB, but CPU speed is 4xFSB....
     
  21. matchboxmatt

    matchboxmatt TS Rookie Topic Starter Posts: 20

    So I should underclock the P4's FSB from 800 to 400?
     
  22. Cinders

    Cinders TechSpot Chancellor Posts: 1,313   +12

    Oops I shouldn't have posted in this thread.
     
  23. captaincranky

    captaincranky TechSpot Addict Posts: 10,821   +922

    Hearsay Evidence.......

    My only authority here was myriad reviews at Newegg. These were referenced to Intel G965WHMK boards. There were also RAM voltage issues as these boards seemed to want 1.85 Volt memory only. The problems arose on DDR2-800 only. The consensus was hooray for Kingston. I can't quote from personal experience, since I wimped out and stuck DDR2 667Mhz in the box. The issue was compounded by the fact the range of BIOS adjustments is limited with Intel boards.
     
  24. CMH

    CMH TechSpot Chancellor Posts: 2,573   +9

    The G965 chipset is one with integrated video on it. I have no experience whatsoever with such boards, but the fact that the integrated video is sharing RAM might be the reason behind it not liking lower latencies.

    As for your FSB, don't worry about it anymore, it should be at "1:1" now.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.