TechSpot

My new wireless Linksys network keeps dropping out

By Casee
Jan 23, 2006
Topic Status:
Not open for further replies.
  1. Last week I installed a new linksys WRT54GS system. It worked perfectly for 5 days and then started dropping out every 3 hours or so. I then disconnected the cable moderm and the Linksys for a few minutes and then reconnected them. About 5 minutes later the signal comes up and everything is fine again. About 3 hours later the same problem appears again. I have checked the cable moderm and there is no problem connecting directly to it. The Linksys is located about 10 feet fron my computer and the all signal bars are green when the signal is showing. Any suggestions as to what I should try would be most appreciated.

    Thank you
  2. Nodsu

    Nodsu Newcomer, in training Posts: 9,431

    Update the Linksys to the most current software.

    "drop out" means what? What exactly fails? Is it the internet connection, the router crashing or perhaps your own computer losing it?
  3. SOcRatEs

    SOcRatEs TechSpot Paladin Posts: 1,382

    Hello! Welcome to TechSpot!

    Just to help a bit, try here:
    Linksys fix

    G'Luck
  4. Casee

    Casee Newcomer, in training Topic Starter

    Nodsu,

    "Drop out" means the signal disappears completely... I still can see the other 2 weak signals in my neighborhood, but the signal from my router is gone. If I then connect ( hardwire) directly to the modem I am back. So the computer is fine and so is the modem.

    Casee
  5. SultanGris

    SultanGris Newcomer, in training Posts: 207

    update router to newest firmware, and update wirless card drivers to the newest drivers, i had the same problem, same router, and thats what fixed it for me.
  6. FireDoc

    FireDoc Newcomer, in training Posts: 20

    Howdie, I have a WRT54GS on a wireless DSL on PPPoe.

    On the opening screen of the html router setup utilitiy it will ask you what kind of connection you have. Select the one that your ISP uses. If it is PPPoe you will need to enter your ISP user name and password that is on your account.

    Also, play with the keep alive - redial period - set it to 20 sec.

    For some reason the following helped out too:

    If you use static PC ip addressing only:

    Enable DHCP
    Starting IP - use a very high number not in your static ip pool - like 248
    Max number of DHCP users - 1
    client lease time = 0
    get your ISP DNS1 and DNS2 addresses and enter them under DHCP settings.

    Are you using the DMZ feature for any reason - like voip - if not disable it - if so static ip it and your DMZ device.

    Good Luck

    FireDoc
  7. SultanGris

    SultanGris Newcomer, in training Posts: 207

    actually you will want your client lease time to be 99999 or whatever is the highest number u can use, if its zero, it will disconnect you every 24 hours while it gets its new info
  8. FireDoc

    FireDoc Newcomer, in training Posts: 20

    Yep, you're right IF DHCP is used. All accounts are static IP. Zero is then a nice default.
  9. Nodsu

    Nodsu Newcomer, in training Posts: 9,431

    First, DHCP has nothing to do with the link layer. Unless your router is crashing because of a buggy DHCP server, DHCP has absolutely no effect on the wireless connection itself.

    Second, DHCP lease time does not mean a period after which you magically get disconnected. As the deadline approahes, your computer renews its DHCP lease and you get your old IP back. If you, for some reason, fail to renew your DHCP lease, then you just get a new IP address.

    In the worst case (IP changes), the result is a termination of all your TCP connections. Every decent network-using program is able to recover from that and resume whatever it was doing before by creating new TCP sessions.
  10. FireDoc

    FireDoc Newcomer, in training Posts: 20

    Yep, you are absolutely correct in all.

    My point is, if you are running static IP's on all PC's and VoiP devices... you need not have DHCP. So, limiting it to 1 (linksys minimum) and setting it to a high value (out of the way - for any future network expansion) all this becomes mute. The way I have sucessfully kept my router and voip certification and registration to my wireless ISP is then by (which I forgot to mention) disable DHCP after DNS, etc. data entry (as a reminder of what this data is). My appologises.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.