TechSpot

My system uses over 90 % of CPU, it slows everything down

By morteez
Aug 29, 2007
  1. Hi,

    Apparently my System uses over 90 % op the CPU, which of course both slows down my laptop a lot and also drains the batteries om my laptop.
    I have a Ace Aspire 5020.
    Sometimes it is alright, but lately It is happening more and more. I've only had the laptop for one year. And it is not over 90 % all the time, it jumps from 50 up to 99% but is usually around 85-90 %.

    I hope you guys can help.
     
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Your laptop is probably being affected by spyware, malware, and and a virus or 2 with all sorts of nasty stuff from AOL to Symantec malfunctions. Can you perform an Operating System restore safely?
     
  3. morteez

    morteez TS Rookie Topic Starter

    I've done virus checks, malware spyware checks and all of that, so I don't think that it's anything like that.
     
  4. LinkedKube

    LinkedKube TechSpot Project Baby Posts: 3,481   +44

    Can you give us complete specifics of the laptop, cpu, ram ?
     
  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Of course you have. Most people say this... Have you installed something recently that may have caused you to notice the slowness, or has it just got slower and slower over time? How old is the laptop?
     
  6. BlameCanada

    BlameCanada TS Rookie Posts: 320

    Are you referring to your 'System Idle Process' ,by any chance :)

    What is the name you see in the Task Manager ?

    To rule out spyware entirely,go HERE and follow all the steps.
     
  7. morteez

    morteez TS Rookie Topic Starter

    thanks all, i figured out what it was, I tried ending the System process, and then a process called CDF.exe or something like that, and I checked it online, and it was Comodo Firewall that was messing things up.
    It's alright now, thanks all
     
  8. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Ahh Comodo Firewall... Did you recently install it? How did you regain speed? Change the firewall's settings?
     
  9. BlameCanada

    BlameCanada TS Rookie Posts: 320

    Well done.

    If it was Comodo,then i can only imagine it was something to with the

    Application Behaviour Analysis.Some people turn that off entirely,but

    if your spyware prone,youd better keep it on.
     
  10. Barney_Calhoun

    Barney_Calhoun TS Rookie Posts: 22

    Maybe its time for a nice reformat?
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...