TechSpot

My sysytem was attacked...pls help(Windows explorer keeps restarting)

By infested
May 29, 2007
Topic Status:
Not open for further replies.
  1. I got a virus on my windows Vista. My windows explorer keeps restarting over and over and over... I've tried everything but it wont work. Even when i start computer in safe mood, it still keeps restarting.
    I have done HJT and the logs is attached. I couldnt do it in safe mode. Please is there anything I can do?? Also my system is running slow and it keeps freezing

    I've run Spy sweeper, Counterspy and Spyware doctor and they found some infected files then I fixed them and after scanning again, they no more find any infected files but my system is still slow and my windows explorer keeps restarting. My toolbar keeps coming and going.

    Attached Files:

  2. momok

    momok TS Rookie Posts: 2,272

    Hi,

    Download LSPFix from HERE.
    1. Disconnect from the Internet, go to the LSPfix file and extract/unzip LSP-Fix into its own folder [C:\lspfix].
    2. Open the lspfix folder and double-click on LSPFix.exe to start the program.
    3. Check the "I know what I am doing" checkbox.
    4. Select (highlight) all instances of 'nlaapi.dll' and 'napinsp.dll' in the left column under "Keep".
    5. Click the arrow >> so it goes over to the right column under "Remove".
    6. Click "Finish" and LSPfix will remove references to the file and restore the chain numbers.
    7. Restart your computer

    You may wish to copy and paste these instructions on notepad for easier reference later.

    Boot into safe mode under your normal user name. See how HERE

    Next turn on "Show all files and folders, including hidden and system". See how HERE

    Go to start > run and type services.msc. Press the enter key.
    Search for the following services. Double click to select stop if they are running. Set the startup type to disabled. Click apply/ok for each service you disable.

    AntiVermins 3.0

    Go to start > Control Panel > Add and Remove Programs.
    Remove anything related to the following:

    AntiVermins 3.0

    After that, run HijackThis and fix the following entries, if found (do this by placing a tick in the check boxes beside these entries and clicking "Fix checked"):

    R3 - URLSearchHook: Yahoo! Toolbar - {EF99BD32-C1FB-11D2-892F-0090271D4F88} - (no file)
    O2 - BHO: (no name) - {7E853D72-626A-48EC-A868-BA8D5E23E045} - (no file)
    O4 - HKLM\..\Run: [AntiVermins 3.0] "C:\Program Files\AntiVermins 3.0\AntiVermins 3.0.exe" /h
    O23 - Service: @%SystemRoot%\system32\qwave.dll,-1 (QWAVE) - Unknown owner - %windir%\system32\svchost.exe (file missing)
    O23 - Service: @%SystemRoot%\system32\seclogon.dll,-7001 (seclogon) - Unknown owner - %windir%\system32\svchost.exe (file missing)
    O23 - Service: STOPzilla Service (szserver) - Unknown owner - C:\Program Files\Common Files\iS3\Anti-Spyware\SZServer.exe (file missing)
    O23 - Service: @%ProgramFiles%\Windows Media Player\wmpnetwk.exe,-101 (WMPNetworkSvc) - Unknown owner - %ProgramFiles%\Windows Media Player\wmpnetwk.exe (file missing)

    Close HJT.


    Navigate in Windows Explorer and delete the following files and folders in bold.

    C:\Program Files\AntiVermins 3.0

    Reboot into normal mode and rehide your protected OS files.

    Thereafter, please post fresh HJT, ComboFix and AVG Antispyware logs from normal mode as attachments into this thread. The utilities can be downloaded from the links in my signature.


    Regards,
    Your friendly momok =)

    This thread is for the use of infested only. Please don't post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
  3. infested

    infested TS Rookie Topic Starter

    LSP-Fix doesnt work on windows Vista
  4. momok

    momok TS Rookie Posts: 2,272

    Hi,

    I take it that you have gone on to complete my other instructions except for LSP Fix part. If you have not, do it after the following.

    Please visit Viruses/Spyware/Malware, preliminary removal instructions and download SpyBot Search & Destroy and AVG Anti Rootkit. These two are compatible with vista.

    Boot into safe mode like previously and unhide all your files and folders.
    Run a full Spybot scan first and let it fix all infections.

    Next, run AVG Anti Rootkit and do a deep scan. Don't fix anything, but note any entries and let me know.

    Now continue with my previous instructions for safe mode if you haven't done them.

    Reboot into normal mode and rehide all your files.

    Thereafter, please post fresh HijackThis, AVG Antispyware and Combofix logs from normal mode as attachments into this thread. Do not copy and paste if not it will be ignored and/or removed.

    Also, please let me know the results of the AVG Antirootkit scan


    Regards,
    Your friendly momok =)

    This thread is for the use of infested only. Please don't post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.