My videocard stopped sending signal to my monitor

By cheesepuff2007
Sep 29, 2007
Topic Status:
Not open for further replies.
  1. Ok so here is my situation i changed my heatsink and cpu fan and then i connected ever thing back. (AMD 3800+) and then when i started it back up my monitor was not getting any signal from my video card (radon 800X)

    I have a asus a8n-sli mother board. (pci slot for the video card). Ok so the fan and everything is running fine it is just the card that is not sending a signal. i tried connceting cables to the blue connector and the white connector on the video card. and none of them are sending signals(sorry i do not know the offical names for the connectors on the vieo card) I tried swithing pci slots but when i put in it in the secondary slot the error light on in the motherboard goes on.

    I noticed that when i was hooking it up on the second pci slot that the metal tip on the card and the metal on the case touched and the lights on my computer ( fan, powersupply, and case) would go on. i dont know if that is relevent but just in case.F.y.i i have an antex 900 case.

    please help i need to know if this might be fixbel or if need a new card thanks!
  2. gavilan

    gavilan Newcomer, in training Posts: 136

    it sounds like you may have fried something. For future reference, always make sure there is no power going to the motherboard before you work on anything hardware related. This means either turning off the switch on the back of the power supply, or unplugging the power cable.
    At this point your best bet is to try a different video card so you can find out what is at fault.
  3. cheesepuff2007

    cheesepuff2007 Newcomer, in training Topic Starter

    yea but the problem was before i noticed the lights go on.
  4. gavilan

    gavilan Newcomer, in training Posts: 136

    if you did the original work with power still connected its still possible you could have burned something out. Do you have another video card that you could try?
  5. cheesepuff2007

    cheesepuff2007 Newcomer, in training Topic Starter

    no i did the orignal work with everything disconnected including the power supply. no i do not have anotehr card i will probably ask my friends to see if i can borrow one just to test.
  6. cheesepuff2007

    cheesepuff2007 Newcomer, in training Topic Starter

    Ok thanks to anyone reading this but i have fixed the problem thanks.
  7. trini20

    trini20 Newcomer, in training

    Same Problem!!

    I got that same problem as you and have done everything you tried. You said you fixed your problem, how did you fix it????
  8. cheesepuff2007

    cheesepuff2007 Newcomer, in training Topic Starter

    it was my cpu, i took it off and surly enough it was mounted wrong and some of the brizzles were bent. So i just straighten them up and mounted it right and it started working. I think i unmounted it when i was changing the heat sink and fan. hope it works, Let me know it it goes .
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.