Mysterious check on floppy-drive

By RealBlackStuff
Nov 23, 2003
Topic Status:
Not open for further replies.
  1. I have Win2000/SP4 on my PC, with Norton-Systemworks 2002 (with Speed Disk disabled), Agnitum Outpost Firewall Pro, Diskeeper 8 Pro and Stardownloader running permanently.

    My (small but nagging) problem: every time I start up, after the desktop is already showing, some program checks my floppy-drive. I have switched off all access to A: in Norton-AV.

    Could this be the network? I have tried everything, but to no avail.
    Is there a sort of monitoring software out, that could tell me what program(s) access the floppy-drive?

    Any help appreciated.
  2. Nodsu

    Nodsu Newcomer, in training Posts: 9,431

    Yes, there are things that let you monitor filesystem access.

    You should try completely disabling services. Start with Norton AV - set it to disabled and reboot.

    Also, you should check if A:\ is in your PATH variable for some reason. Open command prompt, type set and press enter. Look at the PATH variable, does it include references to "A:" or "B:"?
  3. RealBlackStuff

    RealBlackStuff Newcomer, in training Topic Starter Posts: 8,165

    Thanks Nodsu,

    My settings do nor refer to A: or B: anywhere. I also checked all .pif and .lnk files, just in case.

    After NAV disabled + reboot , there is still floppy-access.
    Interestingly, when I enabled NAV again from the System-tray, there was ANOTHER floppy-access. This only works once though, disabling Autoprotection end re-enabling it again does not invoke floppy-access a second time.

    So there must still be another program somewhere.

    I already have set most services to disabled or manual, if I disable any more, my PC won't start.

    You sure it would not be my network? My firewall/router is on 24/7 so that all PCs have the network available at all times.
  4. Nodsu

    Nodsu Newcomer, in training Posts: 9,431

    Network can't have anything to do with that floppy drive access unless you have shared that floppy.

    You can always try booting your PC with network cable unplugged and all networking services disabled..

    When I had that floppy problem, it was because I had A: defined in PATH in autoexec.bat so it didn't show up in System Properties.

    I'm very suspicious about that NAV. Don't just disable it from systray, set all norton system services to disabled.

    Do you have any fishy startup programs?
  5. RealBlackStuff

    RealBlackStuff Newcomer, in training Topic Starter Posts: 8,165

    Using WinXP's MSConfig, by process of elimination, involving umpteen restarts with forever less services going, I finally nailed the bas....d!
    It was the WMI-service (Windows Management Instrumentation) that caused my PC to access the floppy-drive. After checking it out on the web, I found that I can disable both WMI-services. Peace at last.

    NAV still insists on checking floppies as well, no matter WHAT settings I use. Would you know if McAfee checks that drive as well?

    Thanks for your help.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.