TechSpot

Need Help, DVD-R problems

By woody429924
Dec 29, 2006
  1. I have a Toshiba Satellite L25 notebook. It came with a DVD-Rom/CD-R.

    Eventually, that drive stopped burning cd's and it couldn't read burned cd's. It could read commercial cds and dvds, but not burned ones.

    I decided to upgrade, so I bought a combo DVD-R/CD-R drive to replace it with. I shut down the computer, removed the battery, swapped the drives, replaced everything, and started back up.

    Windows found the drive and the little "Found new hardware" bubble popped up. It said it was installed and ready for use. I did another reboot after that, and then tried to burn a data DVD by sending files to the drive. It said there was a problem and it couldn't. I then opened iTunes and burned a normal cd. It worked fine, and read it fine afterwards. But, as soon as it was done burning, windows could not detect the drive. I rebooted, ad it showed up again.

    So, now I have a cd drive that can read and burn cd's and read dvd's. It also seems to uinstall itself after burning a cd.

    What's going on? Is it a software problem? If anyone has any ideas, please let me know.
     
  2. fastco

    fastco TS Booster Posts: 1,122

    Make sure the connectors are tight on the drive and the drive has the latest firmware. Also try a different brand of dvd.
     
  3. woody429924

    woody429924 TS Rookie Topic Starter

    How do I check the firmware?
     
  4. fastco

    fastco TS Booster Posts: 1,122

    Start>Control Panel>System>Device Manager>Hardware then double click the drive and click the Details Tab, scroll down with the arrow to Firmware Revision.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...