TechSpot

Networking probs

By josbd
Nov 21, 2003
  1. Does anyone have any experience with networking 2 pc’s with crossover cable on w2k pro using 2 Ethernet cards and a cable modem connected by USB?

    Yesterday I set up ICS on my main computer by following a guide I found on the Microsoft site.

    After a bit of frustration and re-installing of Ethernet cards I managed to get my main pc to recognise the client and vice versa, and get the client connected to the Internet.

    Late last night, however, the Internet connection on the client pc was no longer working. I can still access the shared folders but when I try a ping test in the “run” box it can’t connect. I have tried changing the IP address on the main pc from 192.168.0.1 to 10.0.0.1 in TCP/IP but this has made no difference.

    I have made sure that the client pc’s Internet Options connection tab has nothing showing, even in the LAN settings.

    Sorry if some of the things I have said in my descriptions are silly but I’m totally new to the whole networking thing.

    I have tried rebooting both pc’s and have tried re-installing the Ethernet card on the client pc but nothing seems to make any difference.

    Can anyone help me and advise me what I have done wrong?!

    Thanks all
     
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 8,165

    On both PCs you must be administrator.

    On your main (gateway) computer, setup ICS as follows:
    (make sure to setup your Internet-connection as per cable-modem instructions)
    In the network and Dial-up Connections folder, right-click the internet connection you want to share and click properties. Click the Sharing tab and select Enable ICS for this connection. If your cable-modem is a dial-up type, enable On-Demand Dialing, else clear.

    On the client PC: In the network and Dial-up Connections folder, right-click the LAN connection and click properties. Select Internet Protocol (TCP/IP) and click properties.
    Select Obtain an IP Address automatically and obtain DNS-server address automatically.
    Click OK till back in network folder and close it.

    Now rightclick Internet Explorer on your desktop, select properties/connections tab.
    Select Never dial a connection, then click LAN Settings, in there clear all check boxes.

    You should realise that the client PC can only connect to the internet if the main PC is switched on.
     
  3. josbd

    josbd TS Enthusiast Topic Starter Posts: 290

    Thanks for that, RBS. That is basically what I did yesterday, and it WAS working for a number of hours, now it isnt. Both pcs are set up as you described, they worked perfectly fine yesterday, today however, theydont. I have tried reinstalling the ethernet drivers on the client pc, and then resetting all of the properties.... I can only connect to the network and not to the internet. Frustration!
     
  4. josbd

    josbd TS Enthusiast Topic Starter Posts: 290

    Addendum, I have just noticed that in the event viewer it is showing warnings for dhcp as follows:

    Your computer has automatically configured the IP address
    for the Network Card with network address 00064F04B9E4.
    The IP address being used is 169.254.96.198.

    Your computer was unable to automatically configure the IP
    parameters for the Network Card with the network address 00064F04B9E4.
    The following error occurred during configuration:
    The parameter is incorrect. .

    Your computer has automatically configured the IP address for
    the Network Card with network address 00064F04B9E4.
    The IP address being used is 169.254.150.229.

    Your computer was not able to renew its address from the
    network (from the DHCP Server) for the Network Card with network
    address 00064F04B9E4. The following error occured:
    The semaphore timeout period has expired. . Your computer will
    continue to try and obtain an address on its own from the network
    address (DHCP) server.

    There are no errors for TCP/IP
     
  5. josbd

    josbd TS Enthusiast Topic Starter Posts: 290

    IDIOCY!! (mine) tis the firewall on the client pc!! erm sorry chaps. But this begs what is probably a really dim question, also: do I need a firewall on the client pc?

    rbs: thanks so much for your time and help.
     
  6. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,647   +323

    No, the firewall on the computer that physically connects will be sufficient. The only exception would be if you were maybe running 2 different firewall types, because if it gets through 1 it can probably get through the other of the same type.
    But basically your best bet is just to not use a firewall on the client, and only on the main one.
     
  7. josbd

    josbd TS Enthusiast Topic Starter Posts: 290

    Excellent! Thanks so much for your help. It is very much appreciated!
     
  8. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 8,165

    Since you live in the UK, I would advice you to have a look at the excellent magazine PCAnswers.
    The amount of stuff I have learned from that magazine is phenomenal. I am now in my 3rd year subscription and I have hardly looked at other mags since

    Website: www.pcanswers.co.uk
    Excellent forum: forum.pcanswers.co.uk
     
  9. josbd

    josbd TS Enthusiast Topic Starter Posts: 290

    Cheers! I'll take a look at that: anything that will teach me more, I would welcome. And the website and forum look excellent. Thanks for the friendly advice chaps.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.