TechSpot

Networking via Crossover...

By thevisigoth
Nov 11, 2006
  1. I've connected my lappy and my desktop via a crossover cable. The desktop has ip=192.168.0.1 and subnet=255.255.255.0 and the lappy has ip=192.168.0.2 and subnet=255.255.255.0 . All other fields in the ethernet card properties, including gateway and dns, are blank.

    I have uninstalled the firewall, even the damn antivirus. Windows' default firewall has been disabled. I ran the "small office or home network" wizard on both PCs to enable file and printer sharing. And this is what's happening:

    I can easily ping one machine from the other, that's ok.
    Now... I can only see the lappy's own shared folders in its "My Network Places" but I cant even see the desktop's shared folders in the desktops "My Network Places". Both machines can ping each other, but they cant see each other. As far as the My Network Places goes, the f**king desktop cant even see itself.

    The workgroup name is the same.

    I've tried everything..

    Need help,

    the ViSigoTH
     
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 21,067   +169

    Try running the network setup utility from your desktop, and enable Inertnet and file sharing from there...
     
  3. Nodsu

    Nodsu TS Rookie Posts: 9,431

    Forget about the network neighbourhood. You can access the shares of the other machine by using the \\ notation. So just put in "\\ip.of.other.machine" in the Windows Explorer address bar, the Run dialog or create a shortcut to it.

    Windows name resolution and network browsing (seeing stuff in network neighbourhood) is a sticky, unreliable and a useless thing.
     
  4. tipstir

    tipstir TS Ambassador Posts: 4,761   +97

    Another way...

    Go into control panel
    Click on Administrator tools
    Click on Local Security Policy
    Click on Local Policies
    Click on Security Options
    Scroll down for Network Access: Sharing and Security
    Change it from Guest to Classic

    Do this for both PCs
    Make sure you have created workgroup name for both PCs
    Static IP address
    Default Gateway for the main PC that connects to the internet...

    Reboot both PCs

    Try it again...
     
  5. thevisigoth

    thevisigoth TS Rookie Topic Starter

    Nothing Works!

    Yes, yes, I've done all of that. Down to the last instruction, but still both my machines cant see each other, though they can still ping each other.

    Damn, what the F**K IS THIS?
    I need to transfer files...

    ANY other suggestions will be thoroughly appreciated...
    the ViSigoTH...
     
  6. tipstir

    tipstir TS Ambassador Posts: 4,761   +97

    I don't like the cross over cable
    I hub or switch gives less trouble...

    ARe you on a domain or workgroup...

    add a new user for both PC
    give it the same password for both
    make both admin
     
  7. Rick

    Rick TechSpot Staff Posts: 6,305   +52 Staff Member

    What's the error message you get when you type \\name_of_computer in Windows Explorer?
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.