New ATI & Nvidia drivers BOTH problematic

By acidosmosis
Nov 10, 2003
  1. I own a ATI Radeon 9700 Pro, and a Geforce 2 MX 400.

    After installing the new Nvidia drivers I noticed that Battlefield 1942 was having a lot of issues with missing textures, invisible walls, floating objects, etc.

    When I installed the new ATI drivers (for Windows 2K/XP) it said the drivers were not certified by Microsoft, so I rebooted to check the installation. After rebooting I noticed that a lot of things were slow, such as the start menu loading, moving/resizing windows, etc. I uninstalled the drivers, rebooted, reinstalled an rebooted hoping the problem was that I should have uninstalled the drivers before updating but the same problem occured.

    So, I uninstalled the new ATI drivers *again* and reinstalled the old drivers (note: I never updated on the last go round, so I am using the 3rd to newest drivers). Then Windows told me same thing saying the drivers were not certified for Microsoft. Since everything was working perfect before I basically said the heck with it, and since it would not allow me to reinstall the older drivers I did a Windows restore to the day before.

    I know a lot of people are having problems with the new Nvidia drivers, but has anyone had problems with the new ATI drivers?
  2. cogenmaster

    cogenmaster TS Enthusiast Posts: 117

    ATI Drivers

    I installed the latest 3.9 cat drivers last week. I have been playing Halo, contract JACK demo, command and conquer generals, and links ls 2003. Have not noted any graphical errors or performance issues. I would think that if I was going to see any performance issues it would be on Halo, for an XBOX port, it sure is system demanding.

    soyo dragon plus
    amd 1700 oc to 1800
    512 ddr 2100
    sound blaster audigy platinum
    ati 9700 pro
  3. 40 oz.

    40 oz. TS Rookie Posts: 17

    The driver slowdown problem for the ATI video drivers is due to the PCI and AGP memory reading options being turned off in the advanced GART functions. I think if you typed "smartgart" or something along those lines in the run command box and turned on those options, should be 4, then 2-d acceleration should be back on in windows and there shouldn't be anymore slowdowns. This happens to me all the time when I installed new Omega drivers, just be patient when Windows loads and it should be ok.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...