TechSpot

New Hard drive on Vista

By javert03
Jun 19, 2009
  1. I put a new 1.5 tb harddrive in my computer, but now that I am trying to format it. It keeps locking up the formatting at 73 %. What do I need to do.
     
  2. Matthew

    Matthew TechSpot Staff Posts: 5,266   +92

    Update your chipset drivers. If you don't know how, post your PC or motherboard brand/model.
     
  3. javert03

    javert03 TS Rookie Topic Starter

    Computer model

    I have an HP a6110n
     
  4. Matthew

    Matthew TechSpot Staff Posts: 5,266   +92

    You running 32-bit or 64-bit Vista? If you respond soon enough I'll try and post the individual SATA driver or the entire nForce package before I head out (if not, I'm sure someone will jump in). You might also be able to get around the issue by looking in (or blindly installing) the optional/hardware updates in Windows Update.
     
  5. javert03

    javert03 TS Rookie Topic Starter

    32 bit Vista. I tried the blind installing a few minutes ago and giving the formatting another shot. If that doesn't work I could use the specific drivers.
     
  6. Matthew

    Matthew TechSpot Staff Posts: 5,266   +92

  7. javert03

    javert03 TS Rookie Topic Starter

    It locked up at 73 percent again. I don't know what to do, but I am getting really tired of it. Thanks for your help though.
     
  8. Matthew

    Matthew TechSpot Staff Posts: 5,266   +92

    I can almost guarantee you it's a driver issue. There is a recognized Nvidia SATA driver problem with Windows where it won't recognize it beyond 1TB or so, which is about 73% of a 1.5TB drive - and I don't think it's coincidental that you have an Nvidia chipset. For example: http://forums.seagate.com/stx/board/message?board.id=ata_drives&message.id=3599&query.id=4249#M3599

    I take it you've tried to use the SATA controller driver above? Don't totally give up. Walk away from the issue for a day if need be and come back with a clear head :).

    *Edit*

    73% of (1.5 terabytes) = 1.09500 terabytes
     
  9. javert03

    javert03 TS Rookie Topic Starter

    ... I loaded it, but I don't think it had installed properly, my power got knocked out by lightening during the install. I reinstalled it and I am now trying again. Hopefully it will work this time.
     
  10. javert03

    javert03 TS Rookie Topic Starter

    Still wouldn't format past 73 %. I just tried splitting it into two images and got 1 tb to format
     
  11. Rick

    Rick TechSpot Staff Posts: 4,573   +65

    Install the driver again and restart your computer, but download and install this one:
    http://www.nvidia.com/object/nforce_vista_15.23.html

    This is a newer version of what Matthew linked. It is also not from HP -- it is from nVidia (the actual manufacturer of your board's chipset)

    We *must* rule out drivers first before looking elsewhere. To do that, you must install the driver again to be certain it installs correctly this time.
     
  12. javert03

    javert03 TS Rookie Topic Starter

    It finally formatted. Those last drivers did the trick, thanks everyone for your help.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...