New Hard Drive

By Grabler
Mar 27, 2004
  1. Hi,

    I installed a new hard drive making it the slave.
    The bios sees it as slave and in windows device manager sees it as a working disk. The problem I have, is Explorer doesn't show it along side with the c drive and my other two CD-Roms.
    I was told I need to format the drive before windows will show it in explorer (my Computer). I have no problem doing a format with windows 98, but windows XP isn't helping. Someone also told me I could format it using disk management in accessories, but I don't have that, must be because I have XP home edition.
    Can anyone tell me what I need to do?

  2. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Right Click on My Computer & click on Manage then go to Disk Management. You can now create new partitions & format them, until you do so the extra space on the new HDD will not be accessible.

    PS. Welcome to TechSpot. Hope you enjoy your stay.:wave:
  3. Grabler

    Grabler TS Rookie Topic Starter

    okay, I see disk mamagement now but the slave drive isn't there, only drive C: and my two cd-rom drives.

    And thank you, glad to be here
  4. Grabler

    Grabler TS Rookie Topic Starter


    I got it now. I am not used to seeing this but I saw the drive was in a window listing below the listing up top.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...