TechSpot

New Hardware Found for USB-printer every time I switch it on.

By RealBlackStuff
Feb 22, 2006
  1. I have a Kyocera FS-1020D laserprinter, connected via USB cable to USB001 (virtual printer port). Running XP-Pro/SP2 with all updates.

    Every time I switch on the printer (or reboot while the printer is already switched on), the New Hardware Found wizard pops up and wants to re-install the drivers. As the installed drivers work perfectly, I just press 'Cancel' and the printer works fine.

    How can I stop XP from finding this printer over and over again?
     
  2. Triton

    Triton TS Enthusiast Posts: 82

    Select View/Show Hidden Devices from Device Manager.
    There may be a "ghost" install of the device. (incorrect or failed install of the driver).
     
  3. RealBlackStuff

    RealBlackStuff TS Rookie Topic Starter Posts: 6,503

    No ghosts on my PC.
    Any other suggestions, perhaps a registry entry?
     
  4. Triton

    Triton TS Enthusiast Posts: 82

  5. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello RBS. Hope you are well.

    Maybe give this a try.

    Go into your device manager.

    Click on the view tab.

    Select show hidden devices.

    Cick the plus sign next to printers.

    Is there an exclamation point? If so select properties, and check and see what it says.

    Try selecting disable from the properties of it, or select uninstall. See if the printer still works.

    I don`t know if that`ll help, but it might.

    Regards Howard :)
     
  6. RealBlackStuff

    RealBlackStuff TS Rookie Topic Starter Posts: 6,503

    There is not, and has never been, an entry for printers under the Device Manger.

    The article referred to by Triton is for parallel printers! (LPT1)
    I'm talking about a USB printer.

    I've reinstalled twice, after deleting all old references in Registry and on the HD.
    It installs as an oemxxx.inf
    That ring a bell for anyone?
     
  7. Triton

    Triton TS Enthusiast Posts: 82

    I saw a post indicating that using the "Found New Hardware" wizard and not installing the printer using the "Add Printer" Wizard can cause this problem.

    You have to uninstall the working printer driver, cancel the "Found New Hardware" wizard on the next boot and properly install the printer using the "Add Printer" Wizard.
     
  8. RealBlackStuff

    RealBlackStuff TS Rookie Topic Starter Posts: 6,503

    I removed all the drivers again, using the installation-CD utility.
    Then I finally RTFM.
    Followed those instructions, but of course crappy XP made its own USB-port (KMUSB002), and it flopped again!
    Assigned it to KMUSB001 and it worked, but...
    Switched the printer off, and then ON again.
    Bleeding XP Hardware Wizard popped up, well, this time I let it go ahead.
    Stupid XP created another USB-port (KMUSB003) and of course it did not work!
    It also created a duplicate printer-entry on my Printer/Fax page.
    Reassigned the printerport to KMUSB001, and it did NOT work either.
    Reassigned it to USB001 (Virtual Printer Port for USB) and all of a sudden, things were working again (like before I started messing).
    However, with 1 big difference!
    After I deleted that duplicate entry, it still worked OK.
    Then printer Off/ON again, and finally NO MORE Wizard!
    Typical Micro$haft crappy interference!

    Anyway, thanks guys, with your combined advise and my perseverance, we managed to get the better once more over M$ Windoze!
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...