New keyboard fails during safe mode boot in XP

By aria1120
Aug 15, 2005
Topic Status:
Not open for further replies.
  1. I recently replaced my Dell keyboard with a mi MICRO Innovations keyboard. When I go to Device Properties it says the keyboard is working, and it types and everything. But when I restart and try to enter Safe Mode I get a Keyboad Fail Strike F1 to continue. The keyboard no longer works by this time so I have to do a hard reboot to get back to my desktop. I've uninstalled the device driver and reinstalled and checked it over and over but everytime I reboot and stike an F key it does the same thing.

    What's happening and how do I fix it so I can log into safe mode?
  2. RealBlackStuff

    RealBlackStuff Newcomer, in training Posts: 8,165

    In your BIOS you can set Stop on all errors EXCEPT keyboard or something like that.
    If it's a USB keyboard, look for other settings in BIOS, quite often also in connection with IRD (infrared). If USB and via hub, put it directly into a PC USB-port.
  3. aria1120

    aria1120 Newcomer, in training Topic Starter

    Well it's hooked up to the modem, but I don't know if it's a USB, I'm no good with names of things. It's got a metal circle with metal spikes in the center and a black rectangle. And um, what are BIOS? :knock:
  4. RealBlackStuff

    RealBlackStuff Newcomer, in training Posts: 8,165

    You have a PS/2 connector on that keyboard. Check that you connect it to the matching PS/2 port for keyboards. On Dell pCs this has the colour orange or purple, and is the one on the LEFT when looking at the back of the PC. The second one is green and is for a PS/2 mouse.
    You do NOT connect a keyboard to your modem.

    BIOS is Basic Input Output System, a chip that controls the basic functions of your PC. This is where some hardware is controlled that is built into your PC.
    When booting up, it should show you what key to press (usually the Del key [or F1 or F2 or F10]) to go into BIOS. You hold that key down during boot, or press it a couple of times, and a menu should show up with BIOS settings. On the first page it will say this 'Stop on all errors' or like it.
    By using the instructions on that screen (either up/down keys, Pageup/Pagedown, or Enter/select from menu), you can change this to NOT stop on keyboard errors.
    Save the changes when done and reboot.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.