TechSpot

New member needing some help

By bree3303
Jan 5, 2006
Topic Status:
Not open for further replies.
  1. Hello... I have an E-machine T2085 that has decided during our recent move it no longer wants to work. I'm not very computer savvy.. so I'm looking for some of you experts to offer some direction. When we tried to turn the computer on.. the tower would come on (with the light) and the monitor flashes a message : Check your PC and Signal cable ... Monitor is working. It flashes that for about 2 minutes.. and then the tower goes down. We had not been having any problems with it prior to our move and it was not damaged in the move at all. Anyone have any ideas or suggestions as to what could be wrong. We have checked all the cables and made sure the outlets were grounded and in working condition.

    Thanks...
  2. Peddant

    Peddant TS Rookie Posts: 1,644

    If you`ve got a video card,check it`s not worked loose or dead.
  3. cyclonicblade

    cyclonicblade TS Rookie Posts: 25

    this may sound dumb but my son moved his puter and came to my saying it did'nt work. Well I looked and instead of jacking the moniter into the GeForce card he pluged it into the intgrated graphics which was automaticly disabled.
    I also had one that got jared and the card creeped up frying the card @ start-up so check that out make sure if its a add in card push it down into the slot.sometimes it looks like it in but its not
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.