New Radeon 9250, system does not recognize ATI display drivers

By Claudius
Oct 28, 2005
  1. I just picked up the card yesterday, and it seems as if my computer recognizes that the card is installed,

    Control Panel > System > Hardware > Devices > Display Adaptors Radeon 9250 + Radeon 9250 secondary >Properties

    "This device is working properly."

    Yet, after following the instructions provided with the card for installation, and installing the software on the CD that came with the card, I reboot, and get this message:

    "The ATI Control Panel failed to initialize because
    no ATI driver is installed, or ATI driver is not working properly. The ATI
    Control Panel will now exit."

    I have been searching for hours on the ATI website on the ATI site I tried downloading various relevent software and got the same result. So far I have not been able to find any answers elsewhere. Any help would be appreciated.

    And yes, my issue might be newbie related, this is the first time I have ever installed a video card. Any help or suggestions would be much appreciated.
  2. zephead

    zephead TechSpot Paladin Posts: 1,569

    have you d/led the latest version of catalyst? if not i advise you do so and install it.
  3. Claudius

    Claudius TS Rookie Topic Starter

    I went into the BIOS and switched it from AGW to PCI, and my card works great.

    Problem solved, I guess I am just a newbie =P
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...