New SBlive Platinum 5.2 Driver boo-boo

By George
Jul 22, 2002
  1. Just dropping a note to all you techs. The New SBLive Platinum 5.1 driver for Windows XP has at least one major boo-boo. They apparently didn't include the driver for the Livedrive in the latest update. So when you uninstall the old drivers, and install the new drivers, guess what? You've now become the owner of $100 of scrap sitting in your 5 1/4 drivebay! This means that the mic imput, the aux in 2, the headphone jack, and the infrared ports do not work. I don't know about the spdif jacks, but suspect that they do not work either. In essence. the livedrive is now non-functional, with the exception of the MIDI port, which appear to work.

    Uninstalling the new software, and re-installing the old software (if you remembered to keep a copy) fixes the problem. Of course, then you are back where you started, which is with pops and crackles for some, haigh latency, and devouring CPU usage.

    In a good note. The rest of the new drivers seem to work well. They have much lower latency, and CPU usage is way down.

    Ah, the Master programers at Creative Labs have struck again!


    Gigabyte GA-7DXR+
    AMD 761 north bridge & VIA 686B south bridge
    Creative CT-5880 sound chip & AC97 codec (disabled)
    Promise ATA133 w/ RAID chip
    NEC USB 2.0 chip (Disabled)
    AMD Athlon Thunderbird 1.4 GB 266 FSB
    512MB PC 2100 266 MHz ram
    Linksys NC100+ Ethernet card
    Efficient Networks 3060 ADSL Modem
    ATI Radeon VE Graphics card
    Soundblaster Live Platinum 5.1 with LiveDrive
    I/O CD-RW
    40 GB Western Digital ATA 100 7200 RPM HDD
    one Standard Floppy
  2. George

    George TS Rookie Topic Starter

    Sorry- That Should Read Soundblaster 5.(1), not 5.2

    Should Read Soundblaster 5.(1), not 5.2
  3. StormBringer

    StormBringer TS Rookie Posts: 2,244

    You can put the LD drivers back in manually.
  4. George

    George TS Rookie Topic Starter

    You can put the LD drivers back in manually.

    By all means. Please explain how I would do that when they are not supplied in the update. I have the previous update, but what would make them work with the new update, since the update wasn't written to include them? And even if I could, would they work with the new software?
  5. StormBringer

    StormBringer TS Rookie Posts: 2,244

    Just extract the setup package(the old one) to a folder, inside you should find another setup app and a few folders. Now just go through the process of updating the LD drivers from Control Panel and let it search your computer for the drivers, it should find them, if not just direct it to them.
  6. George

    George TS Rookie Topic Starter

    installing LD

    I don't just want to reinstall the LD, manually or otherwise. If you reinstall the LD from the old software, it also installs the old drivers. What I want to know is why many of my livedrive features do not work with the new drivers. Here is a list of what doesn't work:

    the headphone jack
    the RCA SPDIF jacks
    the Mic jack
    AUX IN 2

    They work fine with the old Windows xp software.

    In addition, The Infrared ports do not work. I've been told I have to install the remote update. However, in order to do this, you have to have the remote center 1.0 software installed. I don't have a copy of this software, as I bought my sound card right after win2k came out. And Creative took Remote Center 1.0 off their web site and are only offering the update. Go figure.

    Any thoughts, anyone?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...