New widescreen, flickering and artifacts

By JohnK93
Jul 18, 2006
  1. Hi all,
    I just purchased a BenQ 20.1" widescreen LCD. I'm using the DVI connection to my BFG 7800GT. I wanted to test it on same games. Quake 4 ran pretty good, but I did get 1 frozen screen for about 30 seconds. Oblivion also had some artifacts and glitches at the highest res...not sure of all the settings. HL2 had some major glitches during the new game opening video and I had to shut that down...again I'm not sure of the settings, but they were probably maxed. (I was previously using a 17" 1024x768 res, now I'm using 1680x1050) The screen kept going black for a second, then returning. Even after quitting HL2, the flashing continued and I restarted. Everything looks fine during normal windows operation, videos, photoshop, etc. Civ IV ran fine as well, set to the highest settings. It was also hot in my apt, the GPU temp was 56C at idle, 65C under load.

    My question is whether or not one 7800GT will run these games at 1680x1050 (60Hz) at high settings. I haven't tried turning things down yet..I'll try tonight when I get home. If this card is not powerful enough, what can I do to eliminate the artifacts and flickering...what do you think is the best compromise? Lower the resolution? Turn off AA or Dynamic lighting? Do you think the 65C temp is a problem?

    Just looking for your advice.
  2. JohnK93

    JohnK93 TS Rookie Topic Starter Posts: 44

    Card too hot?

    Hello again,
    After using the monitor for a few days, I think that the problem is due to the video card getting too hot. The card is now idling at about 50C. When I play HL2 for about 5 minutes it gets up to 61/62C and then I start seeing artifacts and major stuttering. Settings are mostly on medium, including AA and AF. These temps wouldn't cause problems on my 17" at 1024x768 even at high you think that moving to 20" 1680x1050 made that much of a difference?

  3. zephead

    zephead TechSpot Paladin Posts: 1,569

    yes, these problems could very well be caused by a heat problem. that or a failing power supply usually cause problems of this nature.
    yes, because the card is more heavily loaded and will consume more power, consequentially producing more heat.
    to lower the temperature of your card you can add case fans, or replace the existing ones with fans of higher CFM (cubic feet per minute) ratings. there are also a plethora of gpu coolers on the market that you can install in place of the current cooling hardware (i'm assuming the card is stock).
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...