TechSpot

No audio output device is installed with vista

By jack432
Jun 11, 2007
Topic Status:
Not open for further replies.
  1. ok so i just upgrade to vista and its saying no audio output device is installed and i cant get any sound to come out iam not to good with a pc so i dont know how to fix this my pc is a hp if you need more info just make a post thx for the help
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 25,948   +19

    You need to go to either your soundcard manufactuers website, or if you`re using onboard sound, your mobo manufacturers website and see if they have any Vista compatible drivers. If your system is an oem such as Dell/HP etc, then go to your computer manufacturers website and look for Vista compatible drivers.

    Regards Howard :)
  3. jack432

    jack432 TS Rookie Topic Starter

    ty so much that did the trick =) <3
  4. nao

    nao TS Rookie

    Many people get the "no audio output device" error

    Glad you fixed it. I was without sound for many days until I found some answers on: noaudiooutput dot com. You would be surprised how many people have that problem.
  5. MohammadRastkar

    MohammadRastkar TS Rookie

    You should install a Vista update (Update for Windows Vista (KB929685)).

    Download from here:
    www_4shared_com/file/97604377/14a6ea7/Windows60-KB929685-x86.html

    Microsoft says for this update:
    Install this update to address an issue
    that may prevent high-definition audio devices from initializing
    after resuming the system from a sleep or hibernation state.
    After you install this item, you may have to restart your computer.
  6. BambiSam

    BambiSam TS Rookie

    I have the same problem, but I am currently running Windows 7 and the update will not work for me.

    History of problem:

    Was running Vista Pro worked fine for 1 yr. Windows updated systems 1-2 weeks ago and ran into the problem of no audio devices installed. Looked online tried many "solutions" and did not find answer (Did not find this site till now). I reformatted my computer and installed Windows 7 Pro and on first boot sound returned and I presumed the problem was fixed. But after putting my computer feel asleep (I went to the store while installing programs again) the problem returned.

    In my device manager I have no Game controllers, sound Option when the sound doesnt work. I checked when the sound did work and it was there and I updated the drivers and all. Please help! Thank you much in advance

    Edit: I have checked microsoft for all updates available and none are. I even tried to use the vista one :-\ I wanted to check here before contacting microsoft because that would be an all day event
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.